summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild')
-rw-r--r--dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild b/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild
index b19435e55236..071642860ae7 100644
--- a/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild
+++ b/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild,v 1.1 2015/01/31 19:36:40 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cipher-aes/cipher-aes-0.2.10.ebuild,v 1.2 2015/04/09 07:55:45 slyfox Exp $
EAPI=5
-# ebuild generated by hackport 0.4.4.9999
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: support_aesni:cpu_flags_x86_aes
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="cpu_flags_x86_aes"
RDEPEND="dev-haskell/byteable:=[profile?]
>=dev-haskell/crypto-cipher-types-0.0.6:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
@@ -30,3 +31,8 @@ DEPEND="${RDEPEND}
>=dev-haskell/test-framework-0.3.3
>=dev-haskell/test-framework-quickcheck2-0.2.9 )
"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag cpu_flags_x86_aes support_aesni)
+}