summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/wfmath/wfmath-0.3.6.ebuild')
-rw-r--r--dev-games/wfmath/wfmath-0.3.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-games/wfmath/wfmath-0.3.6.ebuild b/dev-games/wfmath/wfmath-0.3.6.ebuild
new file mode 100644
index 000000000000..5ca7fe2d4750
--- /dev/null
+++ b/dev-games/wfmath/wfmath-0.3.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.6.ebuild,v 1.1 2007/07/21 23:28:59 nyhm Exp $
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ media-libs/atlas-c++"
+
+src_compile() {
+ econf || die
+ emake || die "emake failed"
+ if use doc; then
+ cd doc && emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}