summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/neoengine/neoengine-0.7.0.ebuild')
-rw-r--r--dev-games/neoengine/neoengine-0.7.0.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/dev-games/neoengine/neoengine-0.7.0.ebuild b/dev-games/neoengine/neoengine-0.7.0.ebuild
index 2dd3a8d13a0b..03928befd38d 100644
--- a/dev-games/neoengine/neoengine-0.7.0.ebuild
+++ b/dev-games/neoengine/neoengine-0.7.0.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/neoengine/neoengine-0.7.0.ebuild,v 1.3 2004/06/24 22:13:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/neoengine/neoengine-0.7.0.ebuild,v 1.4 2004/06/29 15:06:26 vapier Exp $
inherit eutils
DESCRIPTION="An Open Source platform independent 3D game engine written in C++"
-SRC_URI="mirror://sourceforge/neoengine/${P}.tar.bz2"
HOMEPAGE="http://www.neoengine.org/"
+SRC_URI="mirror://sourceforge/neoengine/${P}.tar.bz2"
+
LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+
DEPEND="virtual/opengl
media-libs/alsa-lib
doc? ( app-doc/doxygen )"
-KEYWORDS="~ppc ~x86"
-SLOT="0"
-IUSE="doc"
-RESTRICT="nomirror"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-execute.patch
- case ${ARCH} in
- ppc)
- epatch ${FILESDIR}/${PV}-ppc.patch
- ;;
- esac
+ use ppc && epatch ${FILESDIR}/${PV}-ppc.patch
}
src_compile() {
@@ -39,15 +36,15 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
einstall || die "Installation failed"
- dodoc AUTHORS ChangeLog COPYING INSTALL README TODO
+ dodoc AUTHORS ChangeLog INSTALL README TODO
if use doc; then
- mkdir -p ${D}/usr/share/doc/${P}
+ mkdir -p ${D}/usr/share/doc/${PF}
for i in "*-api"; do
- cp -r ${i} ${D}/usr/share/doc/${P};
+ cp -r ${i} ${D}/usr/share/doc/${PF};
done
fi
}