summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash-completion/bash-completion-20060301.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-20060301.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-shells/bash-completion/bash-completion-20060301.ebuild b/app-shells/bash-completion/bash-completion-20060301.ebuild
new file mode 100644
index 000000000000..84458dacae9f
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20060301.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20060301.ebuild,v 1.1 2006/03/02 12:03:27 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| (
+ >=app-shells/bash-2.05a
+ app-shells/zsh
+ )"
+PDEPEND="app-shells/gentoo-bashcomp"
+
+S="${WORKDIR}/${PN/-/_}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="diff" epatch ${FILESDIR}/20050721
+ EPATCH_SUFFIX="diff" epatch ${FILESDIR}/${PV}
+}
+
+src_install() {
+ insinto /etc
+ doins bash_completion || die "failed to install bash_completion"
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion || die "failed to install profile.d"
+
+ # dev-util/subversion provides an extremely superior completion
+ rm contrib/subversion
+ insinto /usr/share/bash-completion
+ doins contrib/* || die "failed to install contrib completions"
+
+ dodoc Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following to your ~/.bashrc to enable completion support."
+ einfo "NOTE: to avoid things like Gentoo bug #98627, you should set aliases"
+ einfo "after sourcing /etc/profile.d/bash-completion."
+ einfo
+ einfo "[[ -f /etc/profile.d/bash-completion ]] && \\ "
+ einfo " source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional completion functions can be enabled by installing"
+ einfo "app-admin/eselect and using the included bashcomp module."
+ echo
+
+ if has_version 'app-shells/zsh' ; then
+ einfo "If you are interested in using the provided bash completion functions with"
+ einfo "zsh, valuable tips on the effective use of bashcompinit are available:"
+ einfo " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ einfo " http://zshwiki.org/ZshSwitchingTo"
+ echo
+ fi
+}