summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rio500/rio500-0.7-r2.ebuild')
-rw-r--r--app-misc/rio500/rio500-0.7-r2.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-misc/rio500/rio500-0.7-r2.ebuild b/app-misc/rio500/rio500-0.7-r2.ebuild
index 362319b0102b..e5ddbb975b01 100644
--- a/app-misc/rio500/rio500-0.7-r2.ebuild
+++ b/app-misc/rio500/rio500-0.7-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r2.ebuild,v 1.9 2006/10/31 12:43:34 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rio500/rio500-0.7-r2.ebuild,v 1.10 2009/01/19 14:29:18 angelos Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Command line tools for transfering mp3s to and from a Rio500"
HOMEPAGE="http://rio500.sourceforge.net/"
@@ -17,8 +17,10 @@ DEPEND="=dev-libs/glib-1.2*"
src_unpack() {
unpack ${A}
- cd "${S}"/src/
- epatch "${FILESDIR}"/${P}_gcc34.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}_gcc34.patch \
+ "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
}
src_compile() {
@@ -26,16 +28,16 @@ src_compile() {
--with-fontpath=/usr/share/rio500/ \
--with-id3support || die
# --with-usbdevfs
- make || die
+ emake || die
}
src_install() {
einstall \
- datadir=${D}/usr/share/rio500 || die
+ datadir="${D}"/usr/share/rio500 || die
#delete /usr/include/getopt.h as it is part of glibc, and shouldn't be
#installed with rio500
- rm ${D}/usr/include/getopt.h 2>/dev/null
+ rm "${D}"/usr/include/getopt.h 2>/dev/null
dodoc AUTHORS ChangeLog NEWS README TODO
dodoc fonts/Readme.txt