summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/clockywock/clockywock-0.2.2.ebuild')
-rw-r--r--app-misc/clockywock/clockywock-0.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/clockywock/clockywock-0.2.2.ebuild b/app-misc/clockywock/clockywock-0.2.2.ebuild
new file mode 100644
index 000000000000..6abce46210eb
--- /dev/null
+++ b/app-misc/clockywock/clockywock-0.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/clockywock/clockywock-0.2.2.ebuild,v 1.1 2006/10/14 16:54:31 tcort Exp $
+
+inherit eutils
+
+DESCRIPTION="ncurses analog clock"
+HOMEPAGE="http://www.soomka.com/"
+SRC_URI="http://www.soomka.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# probably not needed since ncurses is in 'system', but I like to be pedantic
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-cxxflags.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
+src_install() {
+ dobin clockywock
+ dodoc README
+}