summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild')
-rw-r--r--app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild b/app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild
deleted file mode 100644
index 2fcc6458deb7..000000000000
--- a/app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-bridge/scim-bridge-0.4.12.ebuild,v 1.1 2007/04/23 16:19:25 matsuu Exp $
-
-inherit eutils qt3
-
-DESCRIPTION="Yet another IM-client of SCIM"
-HOMEPAGE="http://www.scim-im.org/projects/scim_bridge"
-SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="doc gtk qt3"
-
-DEPEND=">=app-i18n/scim-1.4.6
- gtk? (
- >=x11-libs/gtk+-2.2
- >=x11-libs/pango-1.1
- )
- qt3? (
- $(qt_min_version 3.3.4)
- >=x11-libs/pango-1.1
- )
- doc? ( app-doc/doxygen )"
-
-get_gtk_confdir() {
- if use amd64 || ( [ "${CONF_LIBDIR}" == "lib32" ] && use x86 ) ; then
- echo "/etc/gtk-2.0/${CHOST}"
- else
- echo "/etc/gtk-2.0"
- fi
-}
-
-pkg_setup() {
- if use qt3 && ! built_with_use =x11-libs/qt-3* immqt-bc && ! built_with_use =x11-libs/qt-3* immqt; then
- die "You need to rebuild >=x11-libs/qt-3.3.4 with immqt-bc(recommended) or immqt USE flag enabled."
- fi
-}
-
-src_compile() {
- econf \
- $(use_enable gtk gtk2-immodule) \
- $(use_enable qt3 qt3-immodule) \
- $(use_enable doc documents) || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- elog
- elog "If you would like to use ${PN} as default instead of scim, set"
- elog " $ export GTK_IM_MODULE=scim-bridge"
- elog " $ export QT_IM_MODULE=scim-bridge"
- elog
- [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
-}
-
-pkg_postrm() {
- [ -x /usr/bin/gtk-query-immodules-2.0 ] && gtk-query-immodules-2.0 > "${ROOT}$(get_gtk_confdir)/gtk.immodules"
-}