summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild
new file mode 100644
index 000000000000..0ed6369d0c39
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/fcitx-configtool-0.4.2.ebuild,v 1.1 2012/04/23 10:25:47 qiaomuf Exp $
+
+EAPI="3"
+
+inherit cmake-utils
+
+DESCRIPTION="A gtk GUI to edit fcitx settings"
+HOMEPAGE="http://fcitx.googlecode.com"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk gtk3"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ ~app-i18n/fcitx-4.2.2
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}