summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virt-manager/virt-manager-9999.ebuild')
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
new file mode 100644
index 000000000000..e8890c5df40a
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-9999.ebuild,v 1.14 2013/06/24 13:28:45 cardoe Exp $
+
+EAPI=5
+
+#BACKPORTS=
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+#PYTHON_REQ_USE=""
+
+inherit eutils distutils-r1 fdo-mime gnome2-utils
+
+DESCRIPTION="A graphical tool for administering virtual machines"
+HOMEPAGE="http://virt-manager.org"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gnome-keyring policykit sasl +spice +vnc"
+
+RDEPEND="!app-emulation/virtinst
+ x11-libs/gtk+:3[introspection]
+ >=app-emulation/libvirt-0.7.0[python]
+ >=app-emulation/libvirt-glib-0.0.9
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ x11-libs/vte:2.90[glade,introspection]
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ policykit? ( sys-auth/polkit )
+ spice? ( net-misc/spice-gtk[gtk3,introspection,python,sasl?] )
+ vnc? ( >=net-libs/gtk-vnc-0.3.8[gtk3,introspection,python,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool"
+
+DOCS=( README NEWS )
+
+python_prepare_all() {
+ epatch_user
+ distutils-r1_python_prepare_all
+}
+
+distutils-r1_python_compile() {
+ local defgraphics=
+
+ use vnc && defgraphics="vnc"
+ use spice && defgraphics="spice"
+
+ esetup.py configure \
+ --qemu-user=qemu \
+ --default-graphics=${defgraphics}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ fdo-mime_desktop_database_update
+}