summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mg/mg-20070529.ebuild')
-rw-r--r--app-editors/mg/mg-20070529.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-editors/mg/mg-20070529.ebuild b/app-editors/mg/mg-20070529.ebuild
new file mode 100644
index 000000000000..f527e0cf4702
--- /dev/null
+++ b/app-editors/mg/mg-20070529.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20070529.ebuild,v 1.1 2007/06/25 06:02:10 opfer Exp $
+
+DESCRIPTION="Micro GNU/emacs, a port from the BSDs"
+HOMEPAGE="http://www.xs4all.nl/~hanb/software/mg/"
+SRC_URI="http://www.xs4all.nl/~hanb/software/mg/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/editor"
+
+src_compile() {
+ # econf won't work, as this script does not accept any parameters
+ ./configure || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}