summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/truecrypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog15
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch15
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch51
-rw-r--r--app-crypt/truecrypt/files/truecrypt-4.3a-2.6.29.patch19
-rw-r--r--app-crypt/truecrypt/truecrypt-4.3a.ebuild122
-rw-r--r--app-crypt/truecrypt/truecrypt-6.2a.ebuild107
-rw-r--r--app-crypt/truecrypt/truecrypt-7.0a.ebuild (renamed from app-crypt/truecrypt/truecrypt-6.3a.ebuild)24
7 files changed, 22 insertions, 331 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 3e740cfb2d76..2ed610c82192 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.54 2010/10/13 18:03:22 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.55 2010/10/13 23:10:59 c1pher Exp $
+
+*truecrypt-7.0a (13 Oct 2010)
+
+ 13 Oct 2010; Dane Smith <c1pher@gentoo.org> -truecrypt-4.3a.ebuild,
+ -files/truecrypt-4.3a-2.6.23.patch, -files/truecrypt-4.3a-2.6.24.patch,
+ -files/truecrypt-4.3a-2.6.29.patch, -truecrypt-6.2a.ebuild,
+ -truecrypt-6.3a.ebuild, +truecrypt-7.0a.ebuild:
+ Version bump wrt bug 329075. Uses new license that was already added.
+ truecrypt-stop is now executeable. Addresses bug 234618. Checks
+ CONFIG_CRYPTO_XTS wrt bug 298907. Only warns about the license once. Added
+ a number of missing || die. Thanks Eray Aslan for much of the ebuild
+ clean-up! Also removes all old versions as upstream will no longer provide
+ sources for any of them.
13 Oct 2010; Dane Smith <c1pher@gentoo.org> truecrypt-6.3a.ebuild:
Updated the fetch link wrt bug 335854.
diff --git a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch
deleted file mode 100644
index cfa54bf19adc..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.23.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -urNp truecrypt-4.3a-source-code.org/Linux/Kernel/Dm-target.c truecrypt-4.3a-source-code/Linux/Kernel/Dm-target.c
---- truecrypt-4.3a-source-code.org/Linux/Kernel/Dm-target.c 2007-04-24 19:32:06.000000000 +0300
-+++ truecrypt-4.3a-source-code/Linux/Kernel/Dm-target.c 2007-10-10 23:18:24.000000000 +0200
-@@ -656,7 +656,11 @@ int __init dm_truecrypt_init(void)
- goto err;
- }
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
- bio_ctx_cache = kmem_cache_create ("truecrypt-bioctx", sizeof (struct bio_ctx), 0, 0, NULL, NULL);
-+#else
-+ bio_ctx_cache = kmem_cache_create ("truecrypt-bioctx", sizeof (struct bio_ctx), 0, 0, NULL);
-+#endif
- if (!bio_ctx_cache)
- {
- error ("kmem_cache_create failed");
diff --git a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch
deleted file mode 100644
index eec4aa8bdb9a..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.24.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -Nrup a/Linux/Kernel/Dm-target.c b/Linux/Kernel/Dm-target.c
---- a/Linux/Kernel/Dm-target.c 2007-04-24 18:32:06.000000000 +0200
-+++ b/Linux/Kernel/Dm-target.c 2007-12-22 15:07:56.000000000 +0100
-@@ -375,7 +375,11 @@ static void dereference_bio_ctx (struct
- if (!atomic_dec_and_test (&bc->ref_count))
- return;
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- bio_endio (bc->orig_bio, bc->orig_bio->bi_size, bc->error);
-+#else
-+ bio_endio (bc->orig_bio, bc->error);
-+#endif
- mempool_free (bc, tc->bio_ctx_pool);
- }
-
-@@ -417,24 +421,35 @@ static void work_process (void *qdata)
- }
-
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- static int truecrypt_endio (struct bio *bio, unsigned int bytes_done, int error)
-+#else
-+static int truecrypt_endio (struct bio *bio, int error)
-+#endif
- {
- struct bio_ctx *bc = (struct bio_ctx *) bio->bi_private;
- struct target_ctx *tc = (struct target_ctx *) bc->target->private;
- struct bio_vec *bv;
- int seg_no;
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- trace (1, "end: sc=%llu fl=%ld rw=%ld sz=%d ix=%hd vc=%hd dn=%d er=%d\n",
- (unsigned long long) bio->bi_sector, bio->bi_flags, bio->bi_rw, bio->bi_size, bio->bi_idx, bio->bi_vcnt, bytes_done, error);
-+#else
-+ trace (1, "end: sc=%llu fl=%ld sz=%ld rw=%ld ix=%hd vc=%hd er=%d\n",
-+ (unsigned long long) bio->bi_sector, bio->bi_flags, bio->bi_size, bio->bi_rw, bio->bi_idx, bio->bi_vcnt, error);
-+#endif
-
- if (error != 0)
- bc->error = error;
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)
- if (bio->bi_size)
- {
- trace (2, "Outstanding IO: %d\n", bio->bi_size);
- return 1;
- }
-+#endif
-
- if (bio_data_dir (bio) == READ)
- {
diff --git a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.29.patch b/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.29.patch
deleted file mode 100644
index 1ce09f666bb1..000000000000
--- a/app-crypt/truecrypt/files/truecrypt-4.3a-2.6.29.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- Linux/Kernel/Dm-target.c
-+++ Linux/Kernel/Dm-target.c
-@@ -703,12 +703,16 @@
-
- void __exit dm_truecrypt_exit(void)
- {
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,29)
- int r;
-
- r = dm_unregister_target (&truecrypt_target);
-
- if (r < 0)
- error ("unregister failed %d", r);
-+#else
-+ dm_unregister_target (&truecrypt_target);
-+#endif
-
- destroy_workqueue (work_queue);
- kmem_cache_destroy (bio_ctx_cache);
diff --git a/app-crypt/truecrypt/truecrypt-4.3a.ebuild b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
deleted file mode 100644
index 08aa55e7bbe5..000000000000
--- a/app-crypt/truecrypt/truecrypt-4.3a.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.11 2009/05/18 04:39:01 robbat2 Exp $
-
-#
-# NOTES:
-# - Upstream overwrite CFLAGS, and does not wish us to mess with them.
-# - Upstream insist on hiding the Makefile commands... Don't wish to patch it
-# again.
-# - Some issues with parallel make of user mode library.
-# - Upstream is not responsive, even new kernel versions are not supported
-# by upstream, but by other users.
-#
-
-inherit linux-mod toolchain-funcs multilib
-
-DESCRIPTION="Free open-source disk encryption software"
-HOMEPAGE="http://www.truecrypt.org/"
-SRC_URI="http://www.truecrypt.org/downloads/truecrypt-${PV}-source-code.tar.gz"
-
-LICENSE="truecrypt-collective-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="bindist fetch mirror"
-
-RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
- sys-fs/device-mapper )"
-DEPEND="virtual/linux-sources
- ${RDEPEND}"
-
-S="${WORKDIR}/${P}-source-code"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- dmcrypt_check
- kernel_is lt 2 6 5 && die 'requires at least 2.6.5 kernel version'
-
- BUILD_PARAMS="KERNEL_SRC=${KERNEL_DIR} NO_WARNINGS=1"
- BUILD_TARGETS="truecrypt"
- MODULE_NAMES="truecrypt(block:${S}/Linux/Kernel)"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-2.6.23.patch"
- epatch "${FILESDIR}/${P}-2.6.24.patch"
- epatch "${FILESDIR}/${P}-2.6.29.patch"
-}
-
-src_compile() {
- linux-mod_src_compile || die "Truecrypt module compilation failed."
-
- einfo "Building truecrypt utility"
- cd "${S}/Linux/Cli"
- MAKEOPTS="-j1" emake all NO_STRIP=1 NO_WARNINGS=1 CC="$(tc-getCC)" || die "Compile and/or linking of TrueCrypt Linux CLI application failed."
-}
-
-src_test() {
- "${S}/Linux/Cli/truecrypt" --test || die "tests failed"
-}
-
-src_install() {
- linux-mod_src_install
-
- einfo "Installing truecrypt utility"
- cd "${S}"
- dobin Linux/Cli/truecrypt
- doman Linux/Cli/Man/truecrypt.1
- dodoc Readme.txt 'Release/Setup Files/TrueCrypt User Guide.pdf'
- insinto "/$(get_libdir)/rcscripts/addons"
- newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog " For TrueCrypt 4.2 to work you have to load a "
- elog " kernel module. This can be done in three ways: "
- elog
- elog " 1. Loading the module automatically by the running kernel. "
- elog " For this 'Automatic kernel module loading' needs to be "
- elog " enabled (CONFIG_KMOD=y). "
- elog " 2. Loading the module manually before mounting the volume. "
- elog " Try 'modprobe truecrypt' as root to load the module. "
- elog " 3. Load the module during boot by listing it in "
- elog " '/etc/modules.autoload.d/kernel-2.6' "
-
- warn_license
-}
-
-pkg_preinst() {
- warn_license
-}
-
-dmcrypt_check() {
- ebegin "Checking for Device mapper support (BLK_DEV_DM)"
- linux_chkconfig_present BLK_DEV_DM
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- ewarn "TrueCrypt requires Device mapper support!"
- ewarn "Please enable Device mapper support in your kernel config, found at:"
- ewarn "(for 2.6 kernels)"
- ewarn
- ewarn " Device Drivers"
- ewarn " Multi-Device Support"
- ewarn " <*> Device mapper support"
- ewarn
- ewarn "and recompile your kernel if you want this package to work."
- epause 10
- fi
-}
-
-warn_license() {
- ewarn "TrueCrypt has very restrictive license."
- ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
- ewarn "directory before using TrueCrypt. Please be explicitly aware of"
- ewarn "the limitations on redistribution of binaries or modified source."
- ebeep 5
-}
diff --git a/app-crypt/truecrypt/truecrypt-6.2a.ebuild b/app-crypt/truecrypt/truecrypt-6.2a.ebuild
deleted file mode 100644
index 1b15abae398b..000000000000
--- a/app-crypt/truecrypt/truecrypt-6.2a.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.2a.ebuild,v 1.4 2009/08/31 21:53:26 ikelos Exp $
-
-EAPI="2"
-
-inherit flag-o-matic linux-info multilib toolchain-funcs wxwidgets
-
-DESCRIPTION="Free open-source disk encryption software"
-HOMEPAGE="http://www.truecrypt.org/"
-SRC_URI="${P}.tar.gz"
-
-LICENSE="truecrypt-2.7"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="X"
-RESTRICT="bindist fetch mirror"
-
-RDEPEND="|| ( >=sys-fs/lvm2-2.02.45 sys-fs/device-mapper )
- sys-fs/fuse
- x11-libs/wxGTK:2.8[X?]"
-DEPEND="${RDEPEND}
- || ( dev-libs/pkcs11-helper dev-libs/opensc )"
-RDEPEND="${RDEPEND}
- app-admin/sudo"
-
-S="${WORKDIR}/${P}-source"
-
-pkg_nofetch() {
- elog "Please download tar.gz source from:"
- elog "http://www.truecrypt.org/downloads2.php"
- elog "Then put the file in ${DISTDIR}/${SRC_URI}"
-}
-
-pkg_setup() {
- local CONFIG_CHECK="~BLK_DEV_DM ~DM_CRYPT ~FUSE_FS ~CRYPTO"
- linux-info_pkg_setup
-
- local WX_GTK_VER="2.8"
- if use X; then
- need-wxwidgets unicode
- else
- need-wxwidgets base-unicode
- fi
-}
-
-src_prepare() {
- if has_version x11-libs/wxGTK[X]; then
- # Fix linking when NOGUI=1
- sed -e "s/WX_CONFIG_LIBS := base/&,core/" -i Main/Main.make || die "sed Main/Main.make failed"
- fi
-}
-
-src_compile() {
- local EXTRA pkcs11_include_directory
-
- use X || EXTRA+=" NOGUI=1"
-
- if has_version dev-libs/pkcs11-helper; then
- pkcs11_include_directory="/usr/include/pkcs11-helper-1.0"
- else
- pkcs11_include_directory="/usr/include/opensc"
- fi
- append-flags -DCKR_NEW_PIN_MODE=0x000001B0 -DCKR_NEXT_OTP=0x000001B1
-
- emake \
- ${EXTRA} \
- NOSTRIP=1 \
- NOTEST=1 \
- VERBOSE=1 \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- TC_EXTRA_CFLAGS="${CFLAGS}" \
- TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
- TC_EXTRA_LFLAGS="${LDFLAGS}" \
- WX_CONFIG="${WX_CONFIG}" \
- PKCS11_INC="${pkcs11_include_directory}" \
- || die "emake failed"
-}
-
-src_test() {
- "${S}/Main/truecrypt" --text --test || die "tests failed"
-}
-
-src_install() {
- dobin Main/truecrypt
- dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf"
- insinto "/$(get_libdir)/rcscripts/addons"
- newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
-}
-
-pkg_postinst() {
- warn_license
-}
-pkg_preinst() {
- warn_license
-}
-
-warn_license() {
- ewarn "TrueCrypt has very restrictive license."
- ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
- ewarn "directory before using TrueCrypt. Please be explicitly aware of"
- ewarn "the limitations on redistribution of binaries or modified source."
- ebeep 5
-}
diff --git a/app-crypt/truecrypt/truecrypt-6.3a.ebuild b/app-crypt/truecrypt/truecrypt-7.0a.ebuild
index 6669d653df3f..295fd6d44217 100644
--- a/app-crypt/truecrypt/truecrypt-6.3a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-7.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-6.3a.ebuild,v 1.3 2010/10/13 18:03:22 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.0a.ebuild,v 1.1 2010/10/13 23:10:59 c1pher Exp $
EAPI="2"
@@ -10,7 +10,7 @@ DESCRIPTION="Free open-source disk encryption software"
HOMEPAGE="http://www.truecrypt.org/"
SRC_URI="${P}.tar.gz"
-LICENSE="truecrypt-2.8"
+LICENSE="truecrypt-3.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="X"
@@ -28,12 +28,12 @@ S="${WORKDIR}/${P}-source"
pkg_nofetch() {
elog "Please download .tar.gz source from:"
- elog "http://www.truecrypt.org/pastversions"
+ elog "http://www.truecrypt.org/downloads2"
elog "Then put the file in ${DISTDIR}/${SRC_URI}"
}
pkg_setup() {
- local CONFIG_CHECK="~BLK_DEV_DM ~DM_CRYPT ~FUSE_FS ~CRYPTO"
+ local CONFIG_CHECK="~BLK_DEV_DM ~DM_CRYPT ~FUSE_FS ~CRYPTO ~CRYPTO_XTS"
linux-info_pkg_setup
local WX_GTK_VER="2.8"
@@ -85,23 +85,15 @@ src_test() {
}
src_install() {
- dobin Main/truecrypt
- dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf"
- insinto "/$(get_libdir)/rcscripts/addons"
- newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+ dobin Main/truecrypt || die
+ dodoc Readme.txt "Release/Setup Files/TrueCrypt User Guide.pdf" || die
+ exeinto "/$(get_libdir)/rcscripts/addons"
+ newexe "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh" || die
}
pkg_postinst() {
- warn_license
-}
-pkg_preinst() {
- warn_license
-}
-
-warn_license() {
ewarn "TrueCrypt has very restrictive license."
ewarn "Please read the ${LICENSE} license in ${PORTDIR}/licenses"
ewarn "directory before using TrueCrypt. Please be explicitly aware of"
ewarn "the limitations on redistribution of binaries or modified source."
- ebeep 5
}