summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Exception-Base/ChangeLog9
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild34
-rw-r--r--dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch52
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-perl/Exception-Base/ChangeLog b/dev-perl/Exception-Base/ChangeLog
index 40108cde115d..f16c753ba46d 100644
--- a/dev-perl/Exception-Base/ChangeLog
+++ b/dev-perl/Exception-Base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/Exception-Base
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/ChangeLog,v 1.13 2015/06/13 21:49:28 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/ChangeLog,v 1.14 2015/07/17 18:57:41 dilfridge Exp $
+
+*Exception-Base-0.250.0-r2 (17 Jul 2015)
+
+ 17 Jul 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +Exception-Base-0.250.0-r2.ebuild,
+ +files/Exception-Base-0.250.0-sprintf.patch:
+ Version bump, bug 555206
13 Jun 2015; Andreas K. Huettel <dilfridge@gentoo.org>
Exception-Base-0.250-r1.ebuild:
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
new file mode 100644
index 000000000000..92cdcb705058
--- /dev/null
+++ b/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/Exception-Base-0.250.0-r2.ebuild,v 1.1 2015/07/17 18:57:41 dilfridge Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=DEXTER
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Error handling with exception class"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
+"
+
+SRC_TEST="do parallel"
+
+PATCHES=(
+ "${FILESDIR}/${P}-sprintf.patch"
+)
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}
diff --git a/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch b/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
new file mode 100644
index 000000000000..656c3eba4ee3
--- /dev/null
+++ b/dev-perl/Exception-Base/files/Exception-Base-0.250.0-sprintf.patch
@@ -0,0 +1,52 @@
+From 1cb0ea6afd4bb76e5a1d759efe27ea0f18306a82 Mon Sep 17 00:00:00 2001
+From: Lee Johnson <lee@givengain.ch>
+Date: Thu, 1 Jan 2015 22:33:54 +0000
+Subject: [PATCH] resolve #1 - fix warnings new since perl 5.21.2
+
+Redundant argument in %s - this is because the various calls to the
+sprintf function offset the arrays by 1 (since the first element of
+the array is the sprintf string) but use @_ (the number of elements
+in the array) in the range: 1 .. @_
+
+since it's offset by 1 we are going beyond the end of the array and
+so sprintf consequently warns that we sent more arguments than it
+expected. fix this by using @_ -1 in the range (number of elements
+in the array minus 1)
+---
+ lib/Exception/Base.pm | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/lib/Exception/Base.pm b/lib/Exception/Base.pm
+index 8dce19f..096e2a5 100644
+--- a/lib/Exception/Base.pm
++++ b/lib/Exception/Base.pm
+@@ -1362,7 +1362,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
+ local $_ = ref $self->{$key} eq 'ARRAY'
+ ? sprintf(
+ @{$self->{$key}}[0],
+- @{$self->{$key}}[1..@{$self->{$key}}]
++ @{$self->{$key}}[1..@{$self->{$key}}-1]
+ )
+ : $self->{$key};
+ if (ref $arrval eq 'CODE') {
+@@ -1393,7 +1393,7 @@ sub matches { ## no critic qw(ProhibitExcessComplexity)
+ local $_ = ref $self->{$key} eq 'ARRAY'
+ ? sprintf(
+ @{$self->{$key}}[0],
+- @{$self->{$key}}[1..@{$self->{$key}}]
++ @{$self->{$key}}[1..@{$self->{$key}}-1]
+ )
+ : $self->{$key};
+
+@@ -1613,7 +1613,7 @@ sub _string_attributes {
+ my ($self) = @_;
+
+ return map { ref $_ eq 'ARRAY'
+- ? sprintf(@$_[0], @$_[1..@$_])
++ ? sprintf(@$_[0], @$_[1..@$_-1])
+ : $_ }
+ grep { defined $_ and (ref $_ or $_ ne '') }
+ map { $self->{$_} }
+--
+2.4.5
+