summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/baselayout-lite/ChangeLog5
-rw-r--r--sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild7
-rw-r--r--sys-apps/baselayout/ChangeLog5
-rw-r--r--sys-apps/baselayout/baselayout-1.9.4-r2.ebuild6
4 files changed, 16 insertions, 7 deletions
diff --git a/sys-apps/baselayout-lite/ChangeLog b/sys-apps/baselayout-lite/ChangeLog
index 942aa511818a..197664a8a2bc 100644
--- a/sys-apps/baselayout-lite/ChangeLog
+++ b/sys-apps/baselayout-lite/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/baselayout-lite
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/ChangeLog,v 1.1 2004/02/23 03:19:56 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/ChangeLog,v 1.2 2004/06/15 07:00:26 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> baselayout-lite-1.0_pre1.ebuild:
+ remove unneeded /etc/nsswitch.conf with USE=uclibc
*baselayout-lite-1.0_pre1 (22 Feb 2004)
diff --git a/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
index 22dd25ce59c4..d05814636ee4 100644
--- a/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
+++ b/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild,v 1.2 2004/02/27 20:21:45 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout-lite/baselayout-lite-1.0_pre1.ebuild,v 1.3 2004/06/15 07:00:26 solar Exp $
-IUSE=""
+IUSE="build bootstrap uclibc"
DESCRIPTION="Baselayout for embedded systems"
HOMEPAGE="http://www.gentoo.org/proj/en/base/embedded/"
@@ -19,6 +19,7 @@ src_install() {
insinto /etc
doins ${S}/{fstab,group,nsswitch.conf,passwd,profile.env,protocols,shells}
doins ${S}/init/inittab
+ use uclibc && rm -f ${D}/etc/nsswitch.conf
exeinto /etc/init.d
doexe ${S}/init/rc[SK]
@@ -46,7 +47,7 @@ pkg_postinst() {
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a build.
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! ( use build || use bootstrap )
then
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index f43ef2e285b3..2ebeda4a648a 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.150 2004/06/13 05:04:21 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.151 2004/06/15 06:57:59 solar Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 15 Jun 2004; <solar@gentoo.org> baselayout-1.9.4-r2.ebuild:
+ remove unneeded /etc/nsswitch.conf with USE=uclibc
+
12 Jun 2004; Tom Gall <tgall@gentoo.org> baselayout-1.9.4-r2.ebuild:
adding in /sys for ppc64 bug #52703
diff --git a/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild b/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild
index 490008530db0..af123988dd6f 100644
--- a/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild
+++ b/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild,v 1.3 2004/06/13 05:04:21 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.9.4-r2.ebuild,v 1.4 2004/06/15 06:57:59 solar Exp $
inherit flag-o-matic eutils
@@ -19,7 +19,7 @@ SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/sysvinit-${SVIV}.tar.g
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="bootstrap build livecd static selinux"
+IUSE="bootstrap build livecd static selinux uclibc"
DEPEND="virtual/os-headers
selinux? ( sys-libs/libselinux )"
@@ -426,6 +426,8 @@ src_install() {
dodoc COPYRIGHT README doc/*
fi
+ use uclibc && rm -f ${D}/etc/nsswitch.conf
+
# Hack to fix bug 9849, continued in pkg_postinst
unkdir
}