summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/puppet/ChangeLog10
-rw-r--r--app-admin/puppet/puppet-2.7.24.ebuild181
-rw-r--r--app-admin/puppet/puppet-2.7.25.ebuild181
-rw-r--r--app-admin/puppet/puppet-3.6.2.ebuild189
-rw-r--r--app-admin/puppet/puppet-3.7.1.ebuild189
-rw-r--r--app-admin/puppet/puppet-3.7.2.ebuild189
-rw-r--r--app-admin/puppet/puppet-4.0.0-r1.ebuild (renamed from app-admin/puppet/puppet-4.0.0.ebuild)51
7 files changed, 33 insertions, 957 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index 1b52c3f90b8e..9dd4987161b4 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.215 2015/04/26 17:21:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.216 2015/04/28 20:02:57 prometheanfire Exp $
+
+*puppet-4.0.0-r1 (28 Apr 2015)
+
+ 28 Apr 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +puppet-4.0.0-r1.ebuild, -puppet-2.7.24.ebuild, -puppet-2.7.25.ebuild,
+ -puppet-3.6.2.ebuild, -puppet-3.7.1.ebuild, -puppet-3.7.2.ebuild,
+ -puppet-4.0.0.ebuild:
+ fixing bug 547378
26 Apr 2015; Pacho Ramos <pacho@gentoo.org> puppet-3.7.3.ebuild:
ppc stable wrt bug #536168
diff --git a/app-admin/puppet/puppet-2.7.24.ebuild b/app-admin/puppet/puppet-2.7.24.ebuild
deleted file mode 100644
index 5fd78daa8af1..000000000000
--- a/app-admin/puppet/puppet-2.7.24.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.24.ebuild,v 1.7 2015/04/16 17:54:50 prometheanfire Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-
-inherit elisp-common xemacs-elisp-common eutils ruby-fakegem user
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-KEYWORDS="amd64 hppa ppc sparc x86"
-
-ruby_add_rdepend "
- >=dev-ruby/facter-1.5.6
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-# couchdb? ( dev-ruby/couchrest )
-# mongrel? ( www-servers/mongrel )
-# rack? ( >=dev-ruby/rack-1 )
-# rails? (
-# dev-ruby/rails
-# >=dev-ruby/activerecord-2.1
-# )
-# stomp? ( dev-ruby/stomp )
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- selinux? ( sec-policy/selinux-puppet )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-RUBY_PATCHES=( )
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_fakegem_install() {
- ${RUBY} install.rb --destdir="${D}" install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- insinto /etc/puppet
- # Bug #338439
- #doins conf/gentoo/puppet/*
- doins conf/redhat/puppet.conf
-
- # Location of log and data files
- keepdir /var/{run,log}/puppet
- fowners -R puppet:puppet /var/{run,log}/puppet
-
- if use minimal ; then
- rm "${ED}/usr/bin/puppetmasterd"
- rm "${ED}/etc/puppet/auth.conf"
- else
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
- doins conf/redhat/fileserver.conf
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
- docinto conf; dodoc conf/namespaceauth.conf
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-2.7.25.ebuild b/app-admin/puppet/puppet-2.7.25.ebuild
deleted file mode 100644
index d2944aa47956..000000000000
--- a/app-admin/puppet/puppet-2.7.25.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.25.ebuild,v 1.3 2015/04/16 17:54:50 prometheanfire Exp $
-
-EAPI="5"
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-
-inherit elisp-common xemacs-elisp-common eutils ruby-fakegem user
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-KEYWORDS="~amd64 hppa ~ppc ~sparc ~x86"
-
-ruby_add_rdepend "
- >=dev-ruby/facter-1.5.6
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-# couchdb? ( dev-ruby/couchrest )
-# mongrel? ( www-servers/mongrel )
-# rack? ( >=dev-ruby/rack-1 )
-# rails? (
-# dev-ruby/rails
-# >=dev-ruby/activerecord-2.1
-# )
-# stomp? ( dev-ruby/stomp )
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- selinux? ( sec-policy/selinux-puppet )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-RUBY_PATCHES=( )
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_fakegem_install() {
- ${RUBY} install.rb --destdir="${D}" install
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- insinto /etc/puppet
- # Bug #338439
- #doins conf/gentoo/puppet/*
- doins conf/redhat/puppet.conf
-
- # Location of log and data files
- keepdir /var/{run,log}/puppet
- fowners -R puppet:puppet /var/{run,log}/puppet
-
- if use minimal ; then
- rm "${ED}/usr/bin/puppetmasterd"
- rm "${ED}/etc/puppet/auth.conf"
- else
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
- doins conf/redhat/fileserver.conf
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
- fi
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
- docinto conf; dodoc conf/namespaceauth.conf
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.6.2.ebuild b/app-admin/puppet/puppet-3.6.2.ebuild
deleted file mode 100644
index 7e08cd77e3b8..000000000000
--- a/app-admin/puppet/puppet-3.6.2.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.6.2.ebuild,v 1.5 2015/04/16 17:54:50 prometheanfire Exp $
-
-EAPI="5"
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/rgen-0.6.5 =dev-ruby/rgen-0.6*
- >=dev-ruby/facter-1.6.2 <dev-ruby/facter-3
- dev-ruby/json
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # Avoid Rails specs to avoid this dependency and because they
- # currently fail against Rails 4.1.
- find spec -type f -name '*rails*' -o -name '*active_record*' | xargs rm || die
- rm -r spec/unit/rails || die
- rm spec/unit/parser/collector_spec.rb || die
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb spec/integration/parser/future_compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- #${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.7.1.ebuild b/app-admin/puppet/puppet-3.7.1.ebuild
deleted file mode 100644
index 2a56ce7078a7..000000000000
--- a/app-admin/puppet/puppet-3.7.1.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.7.1.ebuild,v 1.3 2015/04/16 17:54:50 prometheanfire Exp $
-
-EAPI="5"
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/rgen-0.6.5 =dev-ruby/rgen-0.6*
- >=dev-ruby/facter-1.6.2 <dev-ruby/facter-3
- dev-ruby/json
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # Avoid Rails specs to avoid this dependency and because they
- # currently fail against Rails 4.1.
- find spec -type f -name '*rails*' -o -name '*active_record*' | xargs rm || die
- rm -r spec/unit/rails || die
- rm spec/unit/parser/collector_spec.rb || die
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb spec/integration/parser/future_compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- #${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-3.7.2.ebuild b/app-admin/puppet/puppet-3.7.2.ebuild
deleted file mode 100644
index 6895b44e9f46..000000000000
--- a/app-admin/puppet/puppet-3.7.2.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-3.7.2.ebuild,v 1.3 2015/04/16 17:54:50 prometheanfire Exp $
-
-EAPI="5"
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit elisp-common xemacs-elisp-common eutils user ruby-fakegem versionator
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- >=dev-ruby/rgen-0.6.5 =dev-ruby/rgen-0.6*
- >=dev-ruby/facter-1.6.2 <dev-ruby/facter-3
- dev-ruby/json
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl"
-
-DEPEND="${DEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- ruby_targets_ruby19? ( dev-lang/ruby:1.9[yaml] )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # Avoid Rails specs to avoid this dependency and because they
- # currently fail against Rails 4.1.
- find spec -type f -name '*rails*' -o -name '*active_record*' | xargs rm || die
- rm -r spec/unit/rails || die
- rm spec/unit/parser/collector_spec.rb || die
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb spec/integration/parser/future_compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-all_ruby_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- #${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- #systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- newinitd "${FILESDIR}"/puppet.init-r1 puppet
-
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- insinto /etc/puppet
-
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
-
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- if [ "$(get_major_version $REPLACING_VERSIONS)" = "2" ]; then
- elog
- elog "If you're upgrading from 2.x then we strongly suggest you to read:"
- elog "http://docs.puppetlabs.com/guides/upgrading.html"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-4.0.0.ebuild b/app-admin/puppet/puppet-4.0.0-r1.ebuild
index d086b9b49808..fb0453c0f935 100644
--- a/app-admin/puppet/puppet-4.0.0.ebuild
+++ b/app-admin/puppet/puppet-4.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-4.0.0.ebuild,v 1.1 2015/04/16 17:54:50 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-4.0.0-r1.ebuild,v 1.1 2015/04/28 20:02:57 prometheanfire Exp $
EAPI="5"
@@ -17,7 +17,7 @@ SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite3 vim-syntax xemacs"
ruby_add_rdepend "
dev-ruby/hiera
@@ -94,34 +94,25 @@ all_ruby_install() {
newinitd "${FILESDIR}"/puppet.init-r1 puppet
- # Initial configuration files
- insinto /etc/puppet
-
- # Location of log and data files
- keepdir /var/log/puppet
- fowners -R puppet:puppet /var/log/puppet
-
- if use minimal ; then
- rm "${ED}/etc/puppet/auth.conf"
- else
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
- newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppetmaster.service"
+ newinitd "${FILESDIR}"/puppetmaster.init-r1 puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
- insinto /etc/puppet
+ keepdir /etc/puppetlabs/puppet/modules
+ keepdir /etc/puppetlabs/puppet/manifests
- keepdir /etc/puppet/manifests
- keepdir /etc/puppet/modules
+ keepdir /var/lib/puppet/ssl
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+ fperms 0750 /var/lib/puppet
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
- fperms 0750 /var/lib/puppet
- fi
- fperms 0750 /etc/puppet
- fowners :puppet /etc/puppet
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/modules
+ fperms 0750 /etc/puppetlabs/puppet/manifests
+ fowners -R :puppet /etc/puppetlabs
if use emacs ; then
elisp-install ${PN} ext/emacs/puppet-mode.el*
@@ -171,6 +162,12 @@ pkg_postinst() {
elog "http://docs.puppetlabs.com/guides/upgrading.html"
elog
fi
+ if [ "$(get_major_version $REPLACING_VERSIONS)" = "3" ]; then
+ elog
+ elog "If you're upgrading from 3.x then please move everything in /etc/puppet to"
+ elog "/etc/puppetlabs/puppet"
+ elog
+ fi
use emacs && elisp-site-regen
use xemacs && xemacs-elisp-site-regen