summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/mod_auth_kerb/ChangeLog8
-rw-r--r--net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf7
-rw-r--r--net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.111
-rw-r--r--net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch21
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild37
-rw-r--r--net-www/mod_auth_mysql/ChangeLog8
-rw-r--r--net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf129
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-1.111
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-1.11.ebuild30
-rw-r--r--net-www/mod_authenticache/ChangeLog8
-rw-r--r--net-www/mod_authenticache/files/28_mod_authenticache.conf31
-rw-r--r--net-www/mod_authenticache/files/digest-mod_authenticache-2.0.61
-rw-r--r--net-www/mod_authenticache/files/dot-htaccess8
-rw-r--r--net-www/mod_authenticache/files/dot-htpasswd1
-rw-r--r--net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild32
15 files changed, 323 insertions, 0 deletions
diff --git a/net-www/mod_auth_kerb/ChangeLog b/net-www/mod_auth_kerb/ChangeLog
new file mode 100644
index 000000000000..969639b639f4
--- /dev/null
+++ b/net-www/mod_auth_kerb/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_auth_kerb
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.1 2002/11/28 20:30:59 woodchip Exp $
+
+*mod_auth_kerb-4.11 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
new file mode 100644
index 000000000000..58e117c84fd0
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
@@ -0,0 +1,7 @@
+<IfDefine AUTH_KERB>
+ <IfModule !mod_auth_kerb.c>
+ LoadModule kerb_auth_module extramodules/mod_auth_kerb.so
+ </IfModule>
+</IfDefine>
+
+#Place configuration directives here
diff --git a/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11 b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11
new file mode 100644
index 000000000000..4464766cbc16
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11
@@ -0,0 +1 @@
+MD5 2f2c8a52117bfa6248a2c688efb52621 mod_auth_kerb-4.11.tar.gz 14053
diff --git a/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch b/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch
new file mode 100644
index 000000000000..c696324d8b4b
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch
@@ -0,0 +1,21 @@
+--- src/modules/kerberos/mod_auth_kerb.c.orig 2002-09-05 08:21:45.000000000 -0400
++++ src/modules/kerberos/mod_auth_kerb.c 2002-09-05 08:24:25.000000000 -0400
+@@ -1932,11 +1932,18 @@
+ return rec;
+ }
+
++static int kerbauth_init_handler(apr_pool_t *p, apr_pool_t *plog,
++ apr_pool_t *ptemp, server_rec *s)
++{
++ ap_add_version_component(p, "auth_kerberos/4.11");
++ return OK;
++}
+
+ /* register the functions in the correct places */
+ #ifdef APXS2
+ static void register_hooks(apr_pool_t *p)
+ {
++ ap_hook_post_config(kerbauth_init_handler, NULL, NULL, APR_HOOK_MIDDLE);
+ ap_hook_check_user_id(kerb_authenticate_user, NULL, NULL, APR_HOOK_MIDDLE);
+ #ifdef HESIOD
+ ap_hook_access_checker(check_user_access, NULL, NULL, APR_HOOK_MIDDLE);
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild
new file mode 100644
index 000000000000..541c46664e81
--- /dev/null
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild,v 1.1 2002/11/28 20:30:59 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+HOMEPAGE="http://modauthkerb.sourceforge.net/"
+
+S=${WORKDIR}/src
+SRC_URI="mirror://sourceforge/modauthkerb/${P}.tar.gz"
+DEPEND="app-crypt/krb5 =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die;
+ epatch ${FILESDIR}/mod_auth_kerb_register.patch
+}
+
+src_compile() {
+ cd modules/kerberos
+ apxs2 -DAPXS2 -DKRB5 -DKRB5_SAVE_CREDENTIALS \
+ -DKRB_DEF_REALM=\\\"EOS.NCSU.EDU\\\" \
+ -ldl -lkrb5 -lcom_err -lk5crypto -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe modules/kerberos/.libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/11_mod_auth_kerb.conf
+ dodoc ${FILESDIR}/11_mod_auth_kerb.conf
+ #thats all the docs there is right now!
+}
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
new file mode 100644
index 000000000000..678551836213
--- /dev/null
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_auth_mysql
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.1 2002/11/28 20:32:10 woodchip Exp $
+
+*mod_auth_mysql-1.11 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf b/net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf
new file mode 100644
index 000000000000..6d87594c8d85
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf
@@ -0,0 +1,129 @@
+<IfDefine AUTH_MYSQL>
+ <IfModule !mod_auth_mysql.c>
+ LoadModule mysql_auth_module extramodules/mod_auth_mysql.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_auth_mysql.c>
+
+#
+# mod_auth_mysql can be used to limit access to documents by checking
+# data in a MySQL database.
+#
+
+# This will enable user-based MySQL authentication of everything
+# within /home/httpd. You'll need to do the following as the MySQL
+# root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'));
+#
+#<Directory /home/httpd>
+# AuthName "MySQL authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+#
+# require valid-user
+#</Directory>
+
+# This will enable group-based MySQL authentication of everything
+# within /home/httpd. You'll need to do the following as the MySQL
+# root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# user_group CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'), 'user');
+# INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'), 'admin');
+#
+#<Directory /home/httpd>
+# AuthName "MySQL group authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+# AuthMySQLGroupField user_group
+#
+# require group admin
+#</Directory>
+
+# Like the above this enables group-based MySQL authentication of
+# everything within /home/httpd, but this configuration allows users to
+# belong to more than one group. You'll need to do the following as
+# the MySQL root user beforehand:
+#
+# CREATE DATABASE auth;
+# USE auth;
+# CREATE TABLE users (
+# user_name CHAR(30) NOT NULL,
+# user_passwd CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name)
+# );
+# CREATE TABLE groups (
+# user_name CHAR(30) NOT NULL,
+# user_group CHAR(20) NOT NULL,
+# PRIMARY KEY (user_name, user_group)
+# );
+# GRANT SELECT
+# ON auth.users
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+# GRANT SELECT
+# ON auth.groups
+# TO authuser@localhost
+# IDENTIFIED BY 'PaSsW0Rd';
+#
+# INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'));
+# INSERT INTO groups VALUES ('testuser', 'user');
+# INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'));
+# INSERT INTO groups VALUES ('testadmin', 'admin');
+# INSERT INTO groups VALUES ('testadmin', 'user');
+#
+#<Directory /home/httpd>
+# AuthName "MySQL group authenticated zone"
+# AuthType Basic
+#
+# AuthMySQLUser authuser
+# AuthMySQLPassword PaSsW0Rd
+# AuthMySQLDB auth
+# AuthMySQLUserTable users
+# AuthMySQLNameField user_name
+# AuthMySQLPasswordField user_passwd
+# AuthMySQLGroupTable groups
+# AuthMySQLGroupField user_group
+#
+# require group user
+#</Directory>
+
+</IfModule>
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-1.11 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-1.11
new file mode 100644
index 000000000000..76e17c9d9ca9
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-1.11
@@ -0,0 +1 @@
+MD5 612e92542015e5d176428edc28e2b2f1 mod_auth_mysql-1.11-gentoo.tar.bz2 7395
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-1.11.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-1.11.ebuild
new file mode 100644
index 000000000000..16c5c21f92a3
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-1.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-1.11.ebuild,v 1.1 2002/11/28 20:32:10 woodchip Exp $
+
+DESCRIPTION="Basic authentication for Apache2 using a MySQL database"
+HOMEPAGE="ftp://ftp.kciLink.com/pub/"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://gentoo/mod_auth_mysql-1.11-gentoo.tar.bz2"
+DEPEND="=dev-db/mysql-3*"
+RDEPEND="${DEPEND} =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ apxs2 -c ${PN}.c -I/usr/include/mysql -Wl,-lmysqlclient || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/12_mod_auth_mysql.conf
+ cat mod_auth_mysql.c | tail +84 | head -101 \
+ | cut -c 4- > mod_auth_mysql.txt
+ dodoc ${FILESDIR}/12_mod_auth_mysql.conf \
+ mysql-group-auth.txt mod_auth_mysql.txt
+}
diff --git a/net-www/mod_authenticache/ChangeLog b/net-www/mod_authenticache/ChangeLog
new file mode 100644
index 000000000000..fce7b0903282
--- /dev/null
+++ b/net-www/mod_authenticache/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_authenticache
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_authenticache/ChangeLog,v 1.1 2002/11/28 20:34:47 woodchip Exp $
+
+*mod_authenticache-2.0.6 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_authenticache/files/28_mod_authenticache.conf b/net-www/mod_authenticache/files/28_mod_authenticache.conf
new file mode 100644
index 000000000000..b81a1719965f
--- /dev/null
+++ b/net-www/mod_authenticache/files/28_mod_authenticache.conf
@@ -0,0 +1,31 @@
+<IfDefine AUTHENTICACHE>
+ <IfModule !mod_authenticache.c>
+ LoadModule authenticache_module extramodules/mod_authenticache.so
+ </IfModule>
+</IfDefine>
+
+# NOTE!
+# You should login as "test" with the "test" password (without the
+# quotes) to use the example below. You also should enable cookies
+# in your web browser.
+
+<IfModule mod_authenticache.c>
+
+AccessFileName .htaccess
+<Directory _REPLACE_ME_>
+
+ Authenticache On
+ AuthenticacheAuthoritative Off
+ AuthenticacheTTL 600
+ AuthenticacheMaxTTL 3600
+ AuthenticacheTicketName AuthentiCache
+ AuthenticacheTicketPath /
+ AuthenticacheVerifyIP On
+
+ Options None
+ AllowOverride All
+
+</Directory>
+
+</IfModule>
+
diff --git a/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6 b/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6
new file mode 100644
index 000000000000..b1f2a0051eb3
--- /dev/null
+++ b/net-www/mod_authenticache/files/digest-mod_authenticache-2.0.6
@@ -0,0 +1 @@
+MD5 047015199037e9e434e4511bbdfed77b mod_authenticache-2.0.6.tar.bz2 6175
diff --git a/net-www/mod_authenticache/files/dot-htaccess b/net-www/mod_authenticache/files/dot-htaccess
new file mode 100644
index 000000000000..a41d2bfc1100
--- /dev/null
+++ b/net-www/mod_authenticache/files/dot-htaccess
@@ -0,0 +1,8 @@
+AuthUserFile _REPLACE_ME_.htpasswd
+AuthGroupFile /dev/null
+AuthName "Testing mod_authenticache, use test/test as l/p."
+AuthType Basic
+
+<Limit GET>
+ require user test
+</Limit>
diff --git a/net-www/mod_authenticache/files/dot-htpasswd b/net-www/mod_authenticache/files/dot-htpasswd
new file mode 100644
index 000000000000..32ed4cf89530
--- /dev/null
+++ b/net-www/mod_authenticache/files/dot-htpasswd
@@ -0,0 +1 @@
+test:72w6mcwTjDA8A
diff --git a/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
new file mode 100644
index 000000000000..588e76180736
--- /dev/null
+++ b/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_authenticache/mod_authenticache-2.0.6.ebuild,v 1.1 2002/11/28 20:34:47 woodchip Exp $
+
+DESCRIPTION="A generic Apache2 credential caching module"
+HOMEPAGE="http://original.killa.net/infosec/mod_authenticache/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://original.killa.net/infosec/${PN}/${P}.tar.bz2"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND} =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ #fix version string
+ perl -pi -e "s|^#define VERSION .*|#define VERSION \"${PV}\"|g" \
+ defines.h
+ apxs2 -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/28_mod_authenticache.conf
+ dodoc ${FILESDIR}/28_mod_authenticache.conf
+ newdoc ${FILESDIR}/dot-htaccess .htaccess
+ newdoc ${FILESDIR}/dot-htpasswd .htpasswd
+}