summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/shorewall/shorewall-1.4.5-r1.ebuild14
-rw-r--r--net-firewall/shorewall/shorewall-1.4.6-r3.ebuild14
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild21
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild22
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.4.ebuild15
5 files changed, 40 insertions, 46 deletions
diff --git a/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild b/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild
index 0133d7e2958c..125c7f1224a4 100644
--- a/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild
+++ b/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild
@@ -1,23 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild,v 1.4 2003/09/08 07:11:32 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-1.4.5-r1.ebuild,v 1.5 2003/09/10 05:35:12 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Full state iptables firewall"
+HOMEPAGE="http://www.shorewall.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-HOMEPAGE="http://www.shorewall.net"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ppc ~sparc ~alpha"
SLOT="0"
-IUSE=""
+KEYWORDS="x86 ppc ~sparc ~alpha"
DEPEND="virtual/glibc
net-firewall/iptables
sys-apps/iproute"
-RDEPENR=${DEPEND}
-
-src_install () {
+src_install() {
keepdir /var/lib/shorewall
PREFIX=${D} ./install.sh /etc/init.d || die
@@ -25,6 +22,7 @@ src_install () {
newexe ${FILESDIR}/shorewall shorewall
dohtml documentation/*.htm*
}
+
pkg_postinst() {
einfo "Read the documentatition from http://www.shorewall.net"
einfo "and edit the files in /etc/shorewall before starting the firewall"
diff --git a/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild b/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild
index 9d7947cf6cc1..257b6f8d21aa 100644
--- a/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild
+++ b/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild,v 1.2 2003/09/08 07:11:32 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-1.4.6-r3.ebuild,v 1.3 2003/09/10 05:35:12 vapier Exp $
-S=${WORKDIR}/${P}c
DESCRIPTION="Full state iptables firewall"
+HOMEPAGE="http://www.shorewall.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}c.tgz"
-HOMEPAGE="http://www.shorewall.net"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
SLOT="0"
-IUSE=""
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc
net-firewall/iptables
sys-apps/iproute"
-RDEPENR=${DEPEND}
+S=${WORKDIR}/${P}c
-src_install () {
+src_install() {
keepdir /var/lib/shorewall
PREFIX=${D} ./install.sh /etc/init.d || die
@@ -25,6 +24,7 @@ src_install () {
newexe ${FILESDIR}/shorewall shorewall
dohtml documentation/*.htm*
}
+
pkg_postinst() {
einfo "Read the documentatition from http://www.shorewall.net"
einfo "and edit the files in /etc/shorewall before starting the firewall"
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
index 877f163a8b7d..901998e68873 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.10 2003/06/21 21:19:41 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.11 2003/09/10 05:36:49 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Starting and stopping daemontools managed services."
-SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
-KEYWORDS="x86 amd64 ppc sparc "
-SLOT="0"
+SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
+
LICENSE="GPL-2"
-RDEPENDS=">=sys-apps/daemontools-0.70"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc sparc"
+
+RDEPEND=">=sys-apps/daemontools-0.70"
src_compile() {
emake || die
}
src_install() {
- exeinto /usr/bin
- doexe svc-add svc-isdown svc-isup svc-remove \
- svc-start svc-status svc-stop \
- svc-waitdown svc-waitup svscan-add-to-inittab
+ dobin \
+ svc-add svc-isdown svc-isup svc-remove \
+ svc-start svc-status svc-stop \
+ svc-waitdown svc-waitup svscan-add-to-inittab
}
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
index 720e02e3d30b..2db022ac2585 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.1 2003/08/28 20:12:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.2 2003/09/10 05:36:50 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Starting and stopping daemontools managed services."
-SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~hppa ~alpha ~mips "
-SLOT="0"
+SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~hppa ~alpha ~mips "
+
RDEPEND=">=sys-apps/daemontools-0.70"
DEPEND=">=sys-apps/daemontools-0.70
dev-libs/bglibs
@@ -23,12 +24,11 @@ src_compile() {
}
src_install() {
- into /usr
- exeinto /usr/bin
- doexe svc-add svc-isdown svc-isup svc-remove \
- svc-start svc-status svc-stop svc-restart \
- svc-waitdown svc-waitup svscan-add-to-inittab \
- svscan-add-to-inittab svscan-start svscan-stopall
+ dobin \
+ svc-add svc-isdown svc-isup svc-remove \
+ svc-start svc-status svc-stop svc-restart \
+ svc-waitdown svc-waitup svscan-add-to-inittab \
+ svscan-add-to-inittab svscan-start svscan-stopall
dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README TODO VERSION
doman *.[0-9]
}
diff --git a/x11-misc/xrootconsole/xrootconsole-0.4.ebuild b/x11-misc/xrootconsole/xrootconsole-0.4.ebuild
index 89d9e404729e..51ca0ac4d883 100644
--- a/x11-misc/xrootconsole/xrootconsole-0.4.ebuild
+++ b/x11-misc/xrootconsole/xrootconsole-0.4.ebuild
@@ -1,27 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/xrootconsole-0.4.ebuild,v 1.7 2003/09/05 23:18:18 msterret Exp $
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrootconsole/xrootconsole-0.4.ebuild,v 1.8 2003/09/10 05:37:16 vapier Exp $
DESCRIPTION="An utillity that displays its input in a text box on your root window"
-SRC_URI="http://de-fac.to/bob/xrootconsole/${P}.tar.gz"
-
HOMEPAGE="http://de-fac.to/bob/xrootconsole/"
+SRC_URI="http://de-fac.to/bob/xrootconsole/${P}.tar.gz"
LICENSE="GPL-2"
-
-DEPEND="x11-base/xfree"
-RDEPEMD="${DEPEND}"
SLOT="0"
KEYWORDS="x86 sparc "
+DEPEND="x11-base/xfree"
+
src_compile() {
emake || die "emake failed"
}
-src_install () {
- dodir /usr
+src_install() {
dodir /usr/bin
make BINDIR=${D}usr/bin/ install || die "install failed"
}