summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/argus/ChangeLog12
-rw-r--r--net-analyzer/argus/argus-3.0.4.ebuild68
-rw-r--r--net-analyzer/argus/argus-3.0.5.2.ebuild67
-rw-r--r--net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch22
4 files changed, 167 insertions, 2 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 74be841f5b4a..5d5b076fd6c3 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/argus
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.27 2010/10/10 11:03:39 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.28 2011/04/19 22:01:40 jer Exp $
+
+*argus-3.0.5.2 (19 Apr 2011)
+*argus-3.0.4 (19 Apr 2011)
+
+ 19 Apr 2011; Jeroen Roovers <jer@gentoo.org> +argus-3.0.4.ebuild,
+ +files/argus-3.0.4-disable-tcp-wrappers-automagic.patch,
+ +argus-3.0.5.2.ebuild:
+ Version bumps thanks to euscan.
10 Oct 2010; Markos Chandras <hwoarang@gentoo.org> argus-3.0.3.8.ebuild:
Stable on amd64 wrt bug #323577
diff --git a/net-analyzer/argus/argus-3.0.4.ebuild b/net-analyzer/argus/argus-3.0.4.ebuild
new file mode 100644
index 000000000000..0ea1fc40a810
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.4.ebuild,v 1.1 2011/04/19 22:01:40 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch "${FILESDIR}"/${P}-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug} || die
+
+ dodoc ChangeLog CREDITS README || die
+
+ insinto /etc/argus
+ doins support/Config/argus.conf || die
+
+ newinitd "${FILESDIR}/argus.initd" argus || die
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}
diff --git a/net-analyzer/argus/argus-3.0.5.2.ebuild b/net-analyzer/argus/argus-3.0.5.2.ebuild
new file mode 100644
index 000000000000..ec3e4fa46478
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.5.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.2.ebuild,v 1.1 2011/04/19 22:01:40 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug} || die
+
+ dodoc ChangeLog CREDITS README || die
+
+ insinto /etc/argus
+ doins support/Config/argus.conf || die
+
+ newinitd "${FILESDIR}/argus.initd" argus || die
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}
diff --git a/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch b/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch
new file mode 100644
index 000000000000..17ed31bd7d42
--- /dev/null
+++ b/net-analyzer/argus/files/argus-3.0.4-disable-tcp-wrappers-automagic.patch
@@ -0,0 +1,22 @@
+--- configure.ac.org 2011-03-01 00:14:18.000000000 +0100
++++ configure.ac 2011-04-19 23:46:12.000000000 +0200
+@@ -270,6 +270,11 @@
+ LIBS="$LIBS $V_PCAPDEP"
+ fi
+
++AC_ARG_WITH(wrappers,
++ [ --with-wrappers build with libwrappers suuport],
++ with_wrappers="$withval",
++ with_wrappers="yes")
++if test "x$with_wrappers" != "xno"; then
+ AC_QOSIENT_TCPWRAP(V_WRAPDEP, V_INCLS)
+ if test ! -z "$V_WRAPDEP"; then
+ if test -f $V_WRAPDEP; then
+@@ -293,6 +298,7 @@
+ AC_DEFINE([HAVE_TCP_WRAPPER], [], [Using Tcp wrappers])
+ WRAPLIBS="$V_WRAPDEP"
+ fi
++fi
+
+ AC_CHECK_FUNCS(xdrmem_create)
+ if test "$ac_cv_func_xdrmem_create" = yes; then