summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/punc/ChangeLog7
-rw-r--r--sci-libs/punc/files/punc-0.2_p1-libdir.patch15
-rw-r--r--sci-libs/punc/punc-0.2_p1.ebuild8
3 files changed, 24 insertions, 6 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index c0254705a4d5..fcfe17a0f869 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/punc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.2 2010/06/09 11:41:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.3 2010/07/28 15:16:45 flameeyes Exp $
+
+ 28 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> punc-0.2_p1.ebuild,
+ +files/punc-0.2_p1-libdir.patch:
+ Pre-patch the Makefile rather tha after econf (might fix an install
+ failure).
09 Jun 2010; Justin Lecher <jlec@gentoo.org> punc-0.2_p1.ebuild:
Force mpi USE to be equal with deps
diff --git a/sci-libs/punc/files/punc-0.2_p1-libdir.patch b/sci-libs/punc/files/punc-0.2_p1-libdir.patch
new file mode 100644
index 000000000000..b8a973b3aa2d
--- /dev/null
+++ b/sci-libs/punc/files/punc-0.2_p1-libdir.patch
@@ -0,0 +1,15 @@
+Index: punc/src/aaa_lib/Makefile.am
+===================================================================
+--- punc.orig/src/aaa_lib/Makefile.am
++++ punc/src/aaa_lib/Makefile.am
+@@ -88,8 +88,8 @@ else
+ LIBPMG =
+ endif
+
+-libdir = ${prefix}/lib/${fetk_cpu_vendor_os}
+-lib_LTLIBRARIES = libpunc.la ${LIBVF2C} ${LIBBLAS} ${LIBLAPACK} ${LIBSUPERLU} ${LIBARPACK} ${LIBCGCODE} ${LIBPMG}
++mylibdir = ${libdir}/${fetk_cpu_vendor_os}
++mylib_LTLIBRARIES = libpunc.la ${LIBVF2C} ${LIBBLAS} ${LIBLAPACK} ${LIBSUPERLU} ${LIBARPACK} ${LIBCGCODE} ${LIBPMG}
+
+ libpunc_la_SOURCES =
+ libpunc_la_LIBADD = ${BASE_LIBS}
diff --git a/sci-libs/punc/punc-0.2_p1.ebuild b/sci-libs/punc/punc-0.2_p1.ebuild
index a06ad8febf8d..f0bd8e6f6325 100644
--- a/sci-libs/punc/punc-0.2_p1.ebuild
+++ b/sci-libs/punc/punc-0.2_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-0.2_p1.ebuild,v 1.3 2010/06/09 11:41:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-0.2_p1.ebuild,v 1.4 2010/07/28 15:16:46 flameeyes Exp $
EAPI="3"
@@ -31,10 +31,12 @@ S="${WORKDIR}/${PN}"
src_prepare() {
rm -rf src/{blas,lapack,arpack,superlu}
epatch "${FILESDIR}"/${PV}-underlinking.patch
+ epatch "${FILESDIR}"/${P}-libdir.patch
cp tools/tests/pmg/*.f src/pmg/ -f
cp tools/tests/pmg/*.c src/pmg/ -f
cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h
+
eautoreconf
}
@@ -53,10 +55,6 @@ src_configure() {
--enable-pmgforce \
--enable-cgcodeforce \
--enable-vf2cforce
-
- sed -e "s|libdir = \${prefix}/lib/\${fetk_cpu_vendor_os}|libdir = \${prefix}/$(get_libdir)/|" \
- -i src/aaa_lib/Makefile || \
- die "failed to patch lib Makefile"
}
src_install() {