summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libirman/libirman-0.4.2.ebuild9
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.2.ebuild11
-rw-r--r--media-plugins/xmms-extra/xmms-extra-0.1.ebuild10
-rw-r--r--media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild6
-rw-r--r--media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild25
5 files changed, 23 insertions, 38 deletions
diff --git a/media-libs/libirman/libirman-0.4.2.ebuild b/media-libs/libirman/libirman-0.4.2.ebuild
index e04f058fab96..1df9fd473cf6 100644
--- a/media-libs/libirman/libirman-0.4.2.ebuild
+++ b/media-libs/libirman/libirman-0.4.2.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.2.ebuild,v 1.7 2003/02/13 12:48:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.2.ebuild,v 1.8 2003/04/25 14:12:36 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="Libirman is a library for Irman control of Unix software."
+DESCRIPTION="library for Irman control of Unix software"
SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.gz"
HOMEPAGE="http://www.evation.com/libirman/libirman.html"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
DEPEND="virtual/glibc"
@@ -18,7 +17,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
dodir /usr/include
make \
diff --git a/media-libs/sdl-image/sdl-image-1.2.2.ebuild b/media-libs/sdl-image/sdl-image-1.2.2.ebuild
index d5560c4bc02c..edb6fcff1860 100644
--- a/media-libs/sdl-image/sdl-image-1.2.2.ebuild
+++ b/media-libs/sdl-image/sdl-image-1.2.2.ebuild
@@ -1,29 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.2.ebuild,v 1.8 2003/02/13 12:54:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.2.ebuild,v 1.9 2003/04/25 14:13:09 vapier Exp $
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
-DESCRIPTION="SDL-image is an image file loading library"
+DESCRIPTION="image file loading library"
SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
DEPEND=">=media-libs/libpng-1.2.1
>=media-libs/jpeg-6b
>=media-libs/libsdl-1.2"
-
src_compile() {
-
econf || die
emake || die
}
src_install() {
-
- make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
}
diff --git a/media-plugins/xmms-extra/xmms-extra-0.1.ebuild b/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
index 0e53bf87b829..a74cc897dc3c 100644
--- a/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
+++ b/media-plugins/xmms-extra/xmms-extra-0.1.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-extra/xmms-extra-0.1.ebuild,v 1.1 2003/04/18 22:10:28 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-extra/xmms-extra-0.1.ebuild,v 1.2 2003/04/25 14:13:54 vapier Exp $
-DESCRIPTION="xmms-extra is a collection of plugins to xmms"
+DESCRIPTION="extra collection of plugins for xmms"
HOMEPAGE="http://www.xmms.org/files/plugins/xmms-extra/"
SRC_URI="http://www.xmms.org/files/plugins/xmms-extra/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
-RDEPEND=">=xmms-1.2.7"
+
+RDEPEND=">=media-sound/xmms-1.2.7"
src_compile() {
- econf
+ econf || die
emake || die
}
diff --git a/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild b/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
index 299bd7676fa4..a1496fe58b8b 100644
--- a/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
+++ b/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild,v 1.1 2003/02/12 13:00:06 seemant Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-fmradio/xmms-fmradio-1.5.ebuild,v 1.2 2003/04/25 14:14:13 vapier Exp $
MY_P=${P/fmr/FMR}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="XMMS-FMRadio is a radio tuner Plugin for XMMS"
+DESCRIPTION="radio tuner Plugin for XMMS"
HOMEPAGE="http://silicone.free.fr/xmms-FMRadio/"
SRC_URI="http://silicone.free.fr/xmms-FMRadio/${MY_P}.tgz"
diff --git a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
index 0e3224ff20f8..6ec107618127 100644
--- a/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
+++ b/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.5 2003/02/13 13:04:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-shell/xmms-shell-0.99.0-r1.ebuild,v 1.6 2003/04/25 14:15:10 vapier Exp $
-IUSE="readline"
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="XMMS-Shell is a simple utility to control XMMS externally."
+DESCRIPTION="simple utility to control XMMS externally"
SRC_URI="http://download.sourceforge.net/xmms-shell/${P}.tar.gz"
HOMEPAGE="http://www.loganh.com/xmms-shell/"
-DEPEND=">=media-sound/xmms-1.2.7
- readline? ( >=sys-libs/readline-4.1 )"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="readline"
+
+DEPEND=">=media-sound/xmms-1.2.7
+ readline? ( >=sys-libs/readline-4.1 )"
src_unpack() {
unpack ${A}
@@ -23,18 +21,11 @@ src_unpack() {
}
src_compile() {
- local myconf
-
- use readline \
- && myconf="${myconf} --with-readline" \
- || myconf="${myconf} --without-readline"
-
- econf ${myconf} || die "./configure failed"
+ econf `use_with readline` || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
dodoc AUTHORS README
}