summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/test-unit/ChangeLog10
-rw-r--r--dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch32
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.7.ebuild47
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.9.ebuild50
-rw-r--r--dev-ruby/test-unit/test-unit-2.1.0-r1.ebuild (renamed from dev-ruby/test-unit/test-unit-2.1.0.ebuild)6
5 files changed, 12 insertions, 133 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index af4cda853c9a..7655c0408f26 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.22 2010/07/19 10:16:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.23 2010/07/30 17:32:33 flameeyes Exp $
+
+*test-unit-2.1.0-r1 (30 Jul 2010)
+
+ 30 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -test-unit-2.0.7.ebuild, -test-unit-2.0.9.ebuild,
+ -files/test-unit-2.0.9-disable-tests.patch, -test-unit-2.1.0.ebuild,
+ +test-unit-2.1.0-r1.ebuild:
+ Fix install of testrb-2 wrapper, remove old versions.
*test-unit-2.1.0 (19 Jul 2010)
diff --git a/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch b/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch
deleted file mode 100644
index d6dd98fb75e2..000000000000
--- a/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- test/test_assertions.rb.~1~ 2010-05-24 06:46:35.000000000 +0200
-+++ test/test_assertions.rb 2010-06-20 20:49:19.344683987 +0200
-@@ -837,12 +837,6 @@
- assert_in_delta(0.5, 0.4, 0.05, "message")
- }
- object = Object.new
-- check_fails("The arguments must respond to to_f; " +
-- "the first float did not.\n" +
-- "<#{object.inspect}>.respond_to?(:to_f) expected\n" +
-- "(Class: <Object>)") {
-- assert_in_delta(object, 0.4, 0.1)
-- }
- check_fails("The delta should not be negative.\n" +
- "<-0.1> expected to be\n>=\n<0.0>.") {
- assert_in_delta(0.5, 0.4, -0.1, "message")
-@@ -1142,16 +1136,6 @@
- "<#{object.method(:original_method).inspect}> expected") do
- assert_alias_method(object, :other, :original_method)
- end
--
-- check_fails("<#{object.inspect}>.nonexistent doesn't exist\n" +
-- "(Class: <Object>)") do
-- assert_alias_method(object, :nonexistent, :original_method)
-- end
--
-- check_fails("<#{object.inspect}>.nonexistent doesn't exist\n" +
-- "(Class: <Object>)") do
-- assert_alias_method(object, :alias_method, :nonexistent)
-- end
- end
-
- private
diff --git a/dev-ruby/test-unit/test-unit-2.0.7.ebuild b/dev-ruby/test-unit/test-unit-2.0.7.ebuild
deleted file mode 100644
index 5655d6e18bed..000000000000
--- a/dev-ruby/test-unit/test-unit-2.0.7.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.7.ebuild,v 1.3 2010/05/22 16:01:22 flameeyes Exp $
-
-EAPI=2
-# One test fails on jruby, might be a jruby bug
-# When enabled on ruby18 it breaks too many things, so don't enable it for that just yet
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS=""
-IUSE=""
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_intall() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bint/testrb2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.0.9.ebuild b/dev-ruby/test-unit/test-unit-2.0.9.ebuild
deleted file mode 100644
index f376b2a740d2..000000000000
--- a/dev-ruby/test-unit/test-unit-2.0.9.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.9.ebuild,v 1.3 2010/07/03 16:40:09 armin76 Exp $
-
-EAPI=2
-# One test fails on jruby, might be a jruby bug
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
-IUSE=""
-
-# Two tests for jruby currently fail. This has been reported upstream:
-# http://rubyforge.org/tracker/index.php?group_id=5650&atid=21856
-RUBY_PATCHES=( "${P}-disable-tests.patch" )
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_intall() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bint/testrb2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.1.0.ebuild b/dev-ruby/test-unit/test-unit-2.1.0-r1.ebuild
index 51702cf21759..d2f50743ea53 100644
--- a/dev-ruby/test-unit/test-unit-2.1.0.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.0.ebuild,v 1.1 2010/07/19 10:16:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.0-r1.ebuild,v 1.1 2010/07/30 17:32:33 flameeyes Exp $
EAPI=2
# One test fails on jruby, might be a jruby bug
@@ -37,10 +37,10 @@ each_ruby_test() {
${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
}
-all_ruby_intall() {
+all_ruby_install() {
all_fakegem_install
# Create a testrb2 wrapper similarly to the rdoc2 wrapper for
# rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bint/testrb2
+ ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
}