summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/happy/ChangeLog8
-rw-r--r--dev-haskell/happy/happy-1.19.3.ebuild4
-rw-r--r--dev-haskell/happy/happy-1.19.4.ebuild67
3 files changed, 76 insertions, 3 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 72281694c2c5..b0926b1aa97e 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/happy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.74 2014/07/25 08:58:52 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.75 2014/11/15 18:15:35 slyfox Exp $
+
+*happy-1.19.4 (15 Nov 2014)
+
+ 15 Nov 2014; Sergei Trofimovich <slyfox@gentoo.org> +happy-1.19.4.ebuild,
+ happy-1.19.3.ebuild:
+ Version bump.
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/happy/happy-1.19.3.ebuild b/dev-haskell/happy/happy-1.19.3.ebuild
index 18f2fe2c2f13..dcaaf272c468 100644
--- a/dev-haskell/happy/happy-1.19.3.ebuild
+++ b/dev-haskell/happy/happy-1.19.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.19.3.ebuild,v 1.1 2014/02/21 20:06:31 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.19.3.ebuild,v 1.2 2014/11/15 18:15:35 slyfox Exp $
EAPI=5
# ebuild generated by hackport 0.3.4.9999
CABAL_FEATURES="bin test-suite"
-inherit haskell-cabal autotools
+inherit eutils haskell-cabal autotools
DESCRIPTION="Happy is a parser generator for Haskell"
HOMEPAGE="http://www.haskell.org/happy/"
diff --git a/dev-haskell/happy/happy-1.19.4.ebuild b/dev-haskell/happy/happy-1.19.4.ebuild
new file mode 100644
index 000000000000..cfc89d20fae9
--- /dev/null
+++ b/dev-haskell/happy/happy-1.19.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.19.4.ebuild,v 1.1 2014/11/15 18:15:35 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit eutils haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="http://www.haskell.org/happy/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/mtl-1.0
+ >=dev-lang/ghc-6.10.4
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ for f in AttrGrammarParser Parser; do
+ # drop broken autogenerated
+ mv "dist/build/happy/happy-tmp/$f.hs" src/ || die
+ # drop depend on itself, otherwise cabal tries to regenerate it
+ rm "src/$f.ly" || die
+ done
+ use doc && cd doc && eautoconf
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure --with-happy=false
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use doc; then
+ cd doc || die
+ dohtml -r happy/*
+ doman "${S}/doc/happy.1"
+ fi
+}