summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/qosmic/ChangeLog9
-rw-r--r--media-gfx/qosmic/metadata.xml6
-rw-r--r--media-gfx/qosmic/qosmic-1.4.8.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/qosmic/ChangeLog b/media-gfx/qosmic/ChangeLog
new file mode 100644
index 000000000000..dbaf823c26d9
--- /dev/null
+++ b/media-gfx/qosmic/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-gfx/qosmic
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/qosmic/ChangeLog,v 1.1 2009/12/16 10:36:42 ssuominen Exp $
+
+*qosmic-1.4.8 (16 Dec 2009)
+
+ 16 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> +qosmic-1.4.8.ebuild:
+ Initial commit wrt #234695, thanks to David Bitseff and Jouni Rinne.
+
diff --git a/media-gfx/qosmic/metadata.xml b/media-gfx/qosmic/metadata.xml
new file mode 100644
index 000000000000..0e29a8633ffb
--- /dev/null
+++ b/media-gfx/qosmic/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <herd>qt</herd>
+</pkgmetadata>
diff --git a/media-gfx/qosmic/qosmic-1.4.8.ebuild b/media-gfx/qosmic/qosmic-1.4.8.ebuild
new file mode 100644
index 000000000000..13150e44ce7c
--- /dev/null
+++ b/media-gfx/qosmic/qosmic-1.4.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/qosmic/qosmic-1.4.8.ebuild,v 1.1 2009/12/16 10:36:42 ssuominen Exp $
+
+EAPI=2
+inherit qt4
+
+DESCRIPTION="A cosmic recursive flame fractal editor"
+HOMEPAGE="http://code.google.com/p/qosmic/"
+SRC_URI="http://qosmic.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1.4
+ >=media-gfx/flam3-2.7.18
+ >=x11-libs/qt-gui-4.6:4"
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die
+ dodoc changes.txt README
+}