summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/openscenegraph/ChangeLog6
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.0.1-libav-0.7.patch22
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.0.1.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-games/openscenegraph/ChangeLog b/dev-games/openscenegraph/ChangeLog
index 1a6f8605eeb1..d903010d935e 100644
--- a/dev-games/openscenegraph/ChangeLog
+++ b/dev-games/openscenegraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/openscenegraph
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.43 2011/11/17 18:14:20 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/ChangeLog,v 1.44 2011/11/17 18:57:24 reavertm Exp $
+
+ 17 Nov 2011; Maciej Mrozowski <reavertm@gentoo.org>
+ +files/openscenegraph-3.0.1-libav-0.7.patch, openscenegraph-3.0.1.ebuild:
+ Fix the way ffmpeg headers are included, bug 390793.
17 Nov 2011; Maciej Mrozowski <reavertm@gentoo.org> metadata.xml:
Add myself as maintainer.
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.0.1-libav-0.7.patch b/dev-games/openscenegraph/files/openscenegraph-3.0.1-libav-0.7.patch
new file mode 100644
index 000000000000..4748cd48c807
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.0.1-libav-0.7.patch
@@ -0,0 +1,22 @@
+diff -ruN OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp my/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp
+--- OpenSceneGraph-3.0.1/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp 2011-06-17 10:41:56.000000000 +0200
++++ my/src/osgPlugins/ffmpeg/FFmpegHeaders.hpp 2011-11-17 19:44:33.194607494 +0100
+@@ -9,12 +9,13 @@
+ #define FF_API_OLD_SAMPLE_FMT 0
+ #include <errno.h> // for error codes defined in avformat.h
+ #include <stdint.h>
+-#include <avcodec.h>
+-#include <avformat.h>
+-#include <avdevice.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
++#include <libavdevice/avdevice.h>
++#include <libavutil/mathematics.h>
+
+-#ifdef USE_SWSCALE
+- #include <swscale.h>
++#ifdef USE_SWSCALE
++ #include <libswscale/swscale.h>
+ #endif
+
+ }
diff --git a/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild b/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
index 38c5d5698dfc..5b591903b193 100644
--- a/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild,v 1.1 2011/10/14 09:50:30 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/openscenegraph/openscenegraph-3.0.1.ebuild,v 1.2 2011/11/17 18:57:24 reavertm Exp $
EAPI=3
@@ -84,6 +84,7 @@ DOCS=(AUTHORS.txt ChangeLog NEWS.txt)
PATCHES=(
"${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${PN}-3.0.1-libav-0.7.patch"
)
src_configure() {