summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-01-07 21:43:24 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-01-07 21:43:24 +0000
commit0987f866931fa121801ca78e0077c63926a2027b (patch)
treeafd4188a4c99e2f7e94e4eda842e40287425317a /xfce-extra
parentversion bump (diff)
downloadgentoo-2-0987f866931fa121801ca78e0077c63926a2027b.tar.gz
gentoo-2-0987f866931fa121801ca78e0077c63926a2027b.tar.bz2
gentoo-2-0987f866931fa121801ca78e0077c63926a2027b.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.3.1.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog b/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
index 1e2c19f8522a..3c1e2e9b3aaa 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-whiskermenu-plugin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog,v 1.11 2014/01/04 14:33:14 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/ChangeLog,v 1.12 2014/01/07 21:43:24 hasufell Exp $
+
+*xfce4-whiskermenu-plugin-1.3.1 (07 Jan 2014)
+
+ 07 Jan 2014; Julian Ospald <hasufell@gentoo.org>
+ +xfce4-whiskermenu-plugin-1.3.1.ebuild:
+ version bump
04 Jan 2014; Julian Ospald <hasufell@gentoo.org>
xfce4-whiskermenu-plugin-1.3.0.ebuild:
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.3.1.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.3.1.ebuild
new file mode 100644
index 000000000000..ae848cd925ec
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.3.1.ebuild,v 1.1 2014/01/07 21:43:24 hasufell Exp $
+
+EAPI=5
+
+inherit gnome2-utils cmake-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="http://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="http://gottcode.org/xfce4-whiskermenu-plugin/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2
+ xfce-base/exo
+ xfce-base/garcon
+ xfce-base/libxfce4ui
+ xfce-base/libxfce4util
+ xfce-base/xfce4-panel
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ local i
+ cd po || die
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in *.po ; do
+ einfo "removing ${i%.po} linguas"
+ has ${i%.po} ${LINGUAS} || { rm ${i} || die ; }
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}