summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-04-22 16:32:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-04-22 16:32:19 +0000
commit0684a837fccbc1f74ccff693358b56c40475dec1 (patch)
treeafb8eff5851802cd12b16fca8a94ba1b5db624c5 /xfce-extra/xfce4-systemload-plugin
parentRESTRICT="test" because of requirement for running dbus (and also sudo). (diff)
downloadgentoo-2-0684a837fccbc1f74ccff693358b56c40475dec1.tar.gz
gentoo-2-0684a837fccbc1f74ccff693358b56c40475dec1.tar.bz2
gentoo-2-0684a837fccbc1f74ccff693358b56c40475dec1.zip
Fix tooltips with GTK+ >= 2.16 wrt #316685 by Ivan Ponomarev.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-systemload-plugin')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-0.4.2-fix-tooltip-gtk2.12.patch23
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-0.4.2-r1.ebuild39
3 files changed, 71 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/ChangeLog b/xfce-extra/xfce4-systemload-plugin/ChangeLog
index ef8cfc72533b..adbc3910a1f2 100644
--- a/xfce-extra/xfce4-systemload-plugin/ChangeLog
+++ b/xfce-extra/xfce4-systemload-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-systemload-plugin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-systemload-plugin/ChangeLog,v 1.2 2009/10/08 17:44:58 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-systemload-plugin/ChangeLog,v 1.3 2010/04/22 16:32:19 ssuominen Exp $
+
+*xfce4-systemload-plugin-0.4.2-r1 (22 Apr 2010)
+
+ 22 Apr 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-systemload-plugin-0.4.2-r1.ebuild,
+ +files/xfce4-systemload-plugin-0.4.2-fix-tooltip-gtk2.12.patch:
+ Fix tooltips with GTK+ >= 2.16 wrt #316685 by Ivan Ponomarev.
08 Oct 2009; Jeremy Olexa <darkside@gentoo.org>
xfce4-systemload-plugin-0.4.2.ebuild:
diff --git a/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-0.4.2-fix-tooltip-gtk2.12.patch b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-0.4.2-fix-tooltip-gtk2.12.patch
new file mode 100644
index 000000000000..d407678ac427
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-0.4.2-fix-tooltip-gtk2.12.patch
@@ -0,0 +1,23 @@
+diff --git a/panel-plugin/systemload.c b/panel-plugin/systemload.c
+index cc96ec4..027e8fe 100644
+--- a/panel-plugin/systemload.c
++++ b/panel-plugin/systemload.c
+@@ -315,11 +315,18 @@ monitor_control_new(XfcePanelPlugin *plugin)
+ {
+ int count;
+ t_global_monitor *global;
++ GtkSettings *settings;
+
+ tooltips = gtk_tooltips_new ();
+ g_object_ref (tooltips);
+ gtk_object_sink (GTK_OBJECT (tooltips));
+
++ /* reduce the default tooltip timeout to be smaller than the update
++ * interval otherwise we won't see tooltips on GTK 2.16 or newer */
++ settings = gtk_settings_get_default();
++ if (g_object_class_find_property(G_OBJECT_GET_CLASS(settings), "gtk-tooltip-timeout"))
++ g_object_set(settings, "gtk-tooltip-timeout", UPDATE_TIMEOUT - 10, NULL);
++
+ global = g_new(t_global_monitor, 1);
+ global->plugin = plugin;
+ global->timeout_id = 0;
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-0.4.2-r1.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..c11e8d020b73
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-0.4.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-0.4.2-r1.ebuild,v 1.1 2010/04/22 16:32:19 ssuominen Exp $
+
+EAUTORECONF=yes
+EINTLTOOLIZE=yes
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="System load monitor panel plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.us.xfce.org/archive/src/panel-plugins/xfce4-systemload-plugin/0.4/xfce4-systemload-plugin-0.4.2.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/xfce4-panel-4.3.99.1
+ >=xfce-base/libxfcegui4-4.3.99.1
+ >=xfce-base/libxfce4util-4.3.99.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}/${P}-libtool.patch"
+ "${FILESDIR}/${P}-fix-tooltip-gtk2.12.patch" )
+ DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ sed -i -e "/^AC_INIT/s/systemload_version()/systemload_version/" \
+ configure.in || die "sed failed"
+ xfconf_src_prepare
+}