summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-17 14:46:29 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-17 14:46:29 +0000
commitff5f4de146d1d0f011747b50828a2174a0bb98ad (patch)
tree090f3ff1e03510c6a08ed7a0c1bc4e61e119846b /xfce-base
parentVersion bump (diff)
downloadgentoo-2-ff5f4de146d1d0f011747b50828a2174a0bb98ad.tar.gz
gentoo-2-ff5f4de146d1d0f011747b50828a2174a0bb98ad.tar.bz2
gentoo-2-ff5f4de146d1d0f011747b50828a2174a0bb98ad.zip
Version bump with bugfixes. Add slot operators. Fix dependencies.
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/ChangeLog7
-rw-r--r--xfce-base/xfwm4/xfwm4-4.12.3.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index 065f7565862d..1bc373e7a2d6 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.232 2015/03/15 21:43:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.233 2015/05/17 14:46:29 mgorny Exp $
+
+*xfwm4-4.12.3 (17 May 2015)
+
+ 17 May 2015; Michał Górny <mgorny@gentoo.org> +xfwm4-4.12.3.ebuild:
+ Version bump with bugfixes. Add slot operators. Fix dependencies.
*xfwm4-4.12.2 (15 Mar 2015)
diff --git a/xfce-base/xfwm4/xfwm4-4.12.3.ebuild b/xfce-base/xfwm4/xfwm4-4.12.3.ebuild
new file mode 100644
index 000000000000..7e002def5d70
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.12.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.12.3.ebuild,v 1.1 2015/05/17 14:46:29 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug dri startup-notification +xcomposite"
+
+RDEPEND="dev-libs/dbus-glib:=
+ >=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-2.24:2=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/pango:=
+ >=x11-libs/libwnck-2.30:1=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/xfconf-4.10:=
+ startup-notification? ( x11-libs/startup-notification:= )
+ xcomposite? (
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXfixes:=
+ )"
+# libdrm: only headers are used
+# libICE/liBSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig
+ dri? ( >=x11-libs/libdrm-2.4 )"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dri libdrm)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+}