summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-10 07:39:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-10 07:39:37 +0000
commitf5cb178a0de4f741e5066e70332215d03f670a9e (patch)
treebb510e6b6547cdfeb09c824777937d396a1285f4 /xfce-base
parentFixed dependency on openssl (diff)
downloadgentoo-2-f5cb178a0de4f741e5066e70332215d03f670a9e.tar.gz
gentoo-2-f5cb178a0de4f741e5066e70332215d03f670a9e.tar.bz2
gentoo-2-f5cb178a0de4f741e5066e70332215d03f670a9e.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.10.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index f26432232cc8..0a396eb53ff7 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.87 2012/11/28 12:27:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.88 2012/12/10 07:39:37 ssuominen Exp $
+
+*exo-0.10.1 (10 Dec 2012)
+
+ 10 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +exo-0.10.1.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> exo-0.8.0.ebuild:
EAPI5
diff --git a/xfce-base/exo/exo-0.10.1.ebuild b/xfce-base/exo/exo-0.10.1.ebuild
new file mode 100644
index 000000000000..9047865b104c
--- /dev/null
+++ b/xfce-base/exo/exo-0.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.10.1.ebuild,v 1.1 2012/12/10 07:39:37 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}