summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-24 21:06:11 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-24 21:06:11 +0000
commitd6e19de77df1f9c2da7496524b4df827aaf3932d (patch)
tree0275bf704b20cc1a0d8a236db9b7ff881c0ab302 /xfce-base
parentVersion bump. The new version features new translations and drag&drop support. (diff)
downloadgentoo-2-d6e19de77df1f9c2da7496524b4df827aaf3932d.tar.gz
gentoo-2-d6e19de77df1f9c2da7496524b4df827aaf3932d.tar.bz2
gentoo-2-d6e19de77df1f9c2da7496524b4df827aaf3932d.zip
Version bump with bugfixes and translation updates.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/ChangeLog7
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.12.3.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 8711789c541a..a718f5b08e4a 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.262 2015/07/19 12:38:56 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.263 2015/07/24 21:06:11 mgorny Exp $
+
+*xfdesktop-4.12.3 (24 Jul 2015)
+
+ 24 Jul 2015; Michał Górny <mgorny@gentoo.org> +xfdesktop-4.12.3.ebuild:
+ Version bump with bugfixes and translation updates.
19 Jul 2015; Tobias Klausmann <klausman@gentoo.org> xfdesktop-4.12.2.ebuild:
Stable on alpha, bug 553500
diff --git a/xfce-base/xfdesktop/xfdesktop-4.12.3.ebuild b/xfce-base/xfdesktop/xfdesktop-4.12.3.ebuild
new file mode 100644
index 000000000000..dd3b961763e3
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.12.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.12.3.ebuild,v 1.1 2015/07/24 21:06:11 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+# src/xfdesktop-file-utils.c:#if GLIB_CHECK_VERSION (2, 38, 0)
+RDEPEND=">=x11-libs/cairo-1.6:=
+ >=dev-libs/dbus-glib-0.100:=
+ >=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/libwnck-2.30:1=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.8:=
+ >=xfce-base/garcon-0.3:=
+ >=xfce-base/libxfce4ui-4.11:=
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfconf-4.10:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? (
+ >=dev-libs/glib-2.38:=
+ >=xfce-base/thunar-1.6:=[dbus]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}