summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-14 08:40:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-14 08:40:55 +0000
commit92d129d7b1089b87a77eb7c9380bc85dabd9c821 (patch)
treef8777996643241f0f49deeea9cff5e35e80cc87a /xfce-base
parentVersion bump to development release. (diff)
downloadgentoo-2-92d129d7b1089b87a77eb7c9380bc85dabd9c821.tar.gz
gentoo-2-92d129d7b1089b87a77eb7c9380bc85dabd9c821.tar.bz2
gentoo-2-92d129d7b1089b87a77eb7c9380bc85dabd9c821.zip
Version bump to development release.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.7.3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 22718cba74d7..13c9c913e606 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.73 2012/03/30 20:40:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.74 2012/04/14 08:40:55 ssuominen Exp $
+
+*exo-0.7.3 (14 Apr 2012)
+
+ 14 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +exo-0.7.3.ebuild:
+ Version bump to development release.
30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> -exo-0.7.1.ebuild:
old
diff --git a/xfce-base/exo/exo-0.7.3.ebuild b/xfce-base/exo/exo-0.7.3.ebuild
new file mode 100644
index 000000000000..9b7c85f2089f
--- /dev/null
+++ b/xfce-base/exo/exo-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.7.3.ebuild,v 1.1 2012/04/14 08:40:55 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.24
+ dev-perl/URI
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.9
+ >=xfce-base/libxfce4util-4.9"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}