summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-25 09:49:38 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-25 09:49:38 +0000
commit20f49dbe650975f6b575579008af8a61c8409e18 (patch)
tree797c261dabd04e0591e68f6d83f7d4b6dd2350a3 /xfce-base
parentRemove old (diff)
downloadgentoo-2-20f49dbe650975f6b575579008af8a61c8409e18.tar.gz
gentoo-2-20f49dbe650975f6b575579008af8a61c8409e18.tar.bz2
gentoo-2-20f49dbe650975f6b575579008af8a61c8409e18.zip
Version bump with minor bugfixes. Add slot operators.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.10.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index f0664acf84f3..eeae62eb4f81 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.112 2015/03/08 15:06:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.113 2015/03/25 09:49:38 mgorny Exp $
+
+*exo-0.10.4 (25 Mar 2015)
+
+ 25 Mar 2015; Michał Górny <mgorny@gentoo.org> +exo-0.10.4.ebuild:
+ Version bump with minor bugfixes. Add slot operators.
*exo-0.10.3 (08 Mar 2015)
diff --git a/xfce-base/exo/exo-0.10.4.ebuild b/xfce-base/exo/exo-0.10.4.ebuild
new file mode 100644
index 000000000000..129b77e48122
--- /dev/null
+++ b/xfce-base/exo/exo-0.10.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.10.4.ebuild,v 1.1 2015/03/25 09:49:38 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}