summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-16 11:00:57 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-16 11:00:57 +0000
commit488e9113462bdda5439050dacf9319aec2a25ab9 (patch)
tree2057126ad1429213a839583a1c919199cc0b33bc /x11-wm
parentVersion bump. (diff)
downloadgentoo-2-488e9113462bdda5439050dacf9319aec2a25ab9.tar.gz
gentoo-2-488e9113462bdda5439050dacf9319aec2a25ab9.tar.bz2
gentoo-2-488e9113462bdda5439050dacf9319aec2a25ab9.zip
Version bump and update live ebuild.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/ChangeLog8
-rw-r--r--x11-wm/qtile/qtile-0.6.ebuild53
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild22
3 files changed, 72 insertions, 11 deletions
diff --git a/x11-wm/qtile/ChangeLog b/x11-wm/qtile/ChangeLog
index 91ce8cf459d0..9165306c5bd2 100644
--- a/x11-wm/qtile/ChangeLog
+++ b/x11-wm/qtile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/qtile
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.3 2013/03/06 13:34:32 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/ChangeLog,v 1.4 2013/05/16 11:00:57 radhermit Exp $
+
+*qtile-0.6 (16 May 2013)
+
+ 16 May 2013; Tim Harder <radhermit@gentoo.org> +qtile-0.6.ebuild,
+ qtile-9999.ebuild:
+ Version bump and update live ebuild.
06 Mar 2013; Maxim Koltsov <maksbotan@gentoo.org> qtile-9999.ebuild:
Switch 9999 to truly live 'develop' branch per user request.
diff --git a/x11-wm/qtile/qtile-0.6.ebuild b/x11-wm/qtile/qtile-0.6.ebuild
new file mode 100644
index 000000000000..b2c8b79881b8
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.6.ebuild,v 1.1 2013/05/16 11:00:57 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/pycairo-1.10.0-r3[xcb,${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=x11-libs/xpyb-1.3.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ x11-base/xorg-server[kdrive]
+ )"
+
+# tests fail due to xauth errors from python-xlib
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/_build/html/*
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index e3fb0add7520..c1472ca33576 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.3 2013/03/06 13:34:32 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-9999.ebuild,v 1.4 2013/05/16 11:00:57 radhermit Exp $
-EAPI="5"
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit git-2 distutils-r1 virtualx
@@ -18,22 +18,21 @@ SLOT="0"
KEYWORDS=""
IUSE="doc test"
-RDEPEND=">=dev-python/pycairo-1.10.0-r3[xcb]
- dev-python/pygtk:2
- >=x11-libs/xpyb-1.3.1"
-DEPEND="doc? ( dev-python/sphinx )
+RDEPEND=">=dev-python/pycairo-1.10.0-r3[xcb,${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=x11-libs/xpyb-1.3.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
- dev-python/python-xlib
+ dev-python/python-xlib[${PYTHON_USEDEP}]
x11-base/xorg-server[kdrive]
)"
# tests fail due to xauth errors from python-xlib
RESTRICT="test"
-DOCS="TODO.rst"
-
python_compile_all() {
use doc && emake -C docs html
}
@@ -43,6 +42,9 @@ python_test() {
}
python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
use doc && dohtml -r docs/_build/html/*
insinto /usr/share/xsessions