summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-12-08 23:18:55 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-12-08 23:18:55 +0000
commit4642f438b7384fd6d1f34243d8ccccbbeab15300 (patch)
treee870b22f76f2028c91bd6fef6ba1c2d2ef9a0718 /x11-wm
parentAdd amd64 (diff)
downloadgentoo-2-4642f438b7384fd6d1f34243d8ccccbbeab15300.tar.gz
gentoo-2-4642f438b7384fd6d1f34243d8ccccbbeab15300.tar.bz2
gentoo-2-4642f438b7384fd6d1f34243d8ccccbbeab15300.zip
Dropping old version
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/ChangeLog8
-rw-r--r--x11-wm/windowmaker/files/0.91.0/64bit+endian-fixes-0.9x.patch166
-rw-r--r--x11-wm/windowmaker/files/0.91.0/maximize-fix-0.9x.patch33
-rw-r--r--x11-wm/windowmaker/files/0.91.0/menufocus.patch37
-rw-r--r--x11-wm/windowmaker/files/digest-windowmaker-0.91.0-r16
-rw-r--r--x11-wm/windowmaker/windowmaker-0.91.0-r1.ebuild184
6 files changed, 7 insertions, 427 deletions
diff --git a/x11-wm/windowmaker/ChangeLog b/x11-wm/windowmaker/ChangeLog
index 7910d4873f0e..e46b3b62e4ec 100644
--- a/x11-wm/windowmaker/ChangeLog
+++ b/x11-wm/windowmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/windowmaker
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.92 2007/11/22 22:09:59 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.93 2007/12/08 23:18:54 voyageur Exp $
+
+ 08 Dec 2007; Bernard Cafarelli <voyageur@gentoo.org>
+ -files/0.91.0/64bit+endian-fixes-0.9x.patch,
+ -files/0.91.0/maximize-fix-0.9x.patch, -files/0.91.0/menufocus.patch,
+ -windowmaker-0.91.0-r1.ebuild:
+ Dropping old version, please use 0.92.0-r*
*windowmaker-0.92.0-r7 (22 Nov 2007)
diff --git a/x11-wm/windowmaker/files/0.91.0/64bit+endian-fixes-0.9x.patch b/x11-wm/windowmaker/files/0.91.0/64bit+endian-fixes-0.9x.patch
deleted file mode 100644
index c922fc965789..000000000000
--- a/x11-wm/windowmaker/files/0.91.0/64bit+endian-fixes-0.9x.patch
+++ /dev/null
@@ -1,166 +0,0 @@
-diff -ur WindowMaker-0.91.0/src/wmspec.c WindowMaker-0.91.0-test/src/wmspec.c
---- WindowMaker-0.91.0/src/wmspec.c 2004-10-24 15:36:15.000000000 -0400
-+++ WindowMaker-0.91.0-test/src/wmspec.c 2005-03-13 14:25:18.860008096 -0500
-@@ -27,6 +27,7 @@
-
- #include <X11/Xlib.h>
- #include <X11/Xatom.h>
-+#include <X11/Xarch.h>
- #include <string.h>
-
- #include "WindowMaker.h"
-@@ -314,15 +315,15 @@
- void
- wNETWMUpdateDesktop(WScreen *scr)
- {
-- CARD32 *views, sizes[2];
-+ long *views, sizes[2];
- int count, i;
-
- if (scr->workspace_count==0)
- return;
-
- count = scr->workspace_count * 2;
-- views = wmalloc(sizeof(CARD32) * count);
-- /*memset(views, 0, sizeof(CARD32) * count);*/
-+ views = wmalloc(sizeof(long) * count);
-+ /*memset(views, 0, sizeof(long) * count);*/
-
- #ifdef VIRTUAL_DESKTOP
- sizes[0] = scr->workspaces[scr->current_workspace]->width;
-@@ -362,7 +363,7 @@
- 0, 1, &count);
- if (prop)
- {
-- int desktop= *(CARD32*)prop;
-+ int desktop= *(long*)prop;
- XFree(prop);
- return desktop;
- }
-@@ -382,40 +383,54 @@
- &nitems_return, &bytes_after_return, &prop_return);
-
- if (rc==Success && prop_return) {
-- unsigned int *data = (unsigned int *)prop_return;
-+ unsigned long *data = (unsigned long *)prop_return;
- unsigned int pos = 0, len = 0;
- unsigned int best_pos = 0, best_tmp = ~0;
-+ unsigned int tmp;
- extern WPreferences wPreferences;
- unsigned int pref_size = wPreferences.icon_size;
- unsigned int pref_sq = pref_size*pref_size;
-- char *src, *dst;
-+ unsigned char *src, *dst;
- RImage *new_rimage;
-
- do {
- len = data[pos+0]*data[pos+1];
-- unsigned int tmp = pref_sq-len;
-+ tmp = pref_sq-len;
- if (tmp < best_tmp && tmp > 0) {
- best_tmp = tmp;
-- best_pos = pos;
-+ best_pos = pos+2;
- }
- pos += 2+len;
- } while (pos < nitems_return && len != 0);
-
-- new_rimage = RCreateImage(data[best_pos+0], data[best_pos+1], True);
-- len = data[best_pos+0] * data[best_pos+1];
-- src = (char*)&data[best_pos+2];
-- dst = new_rimage->data;
-- for (pos=0; pos<len; ++pos, src+=4, dst+=4) {
-- dst[0] = src[2]; /* R */
-- dst[1] = src[1]; /* G */
-- dst[2] = src[0]; /* B */
-- dst[3] = src[3]; /* A */
-- }
-+ if ( best_pos < 2 ) best_pos = 2;
-+
-+ new_rimage = RCreateImage(data[best_pos-2], data[best_pos-1], True);
-
- if (new_rimage) {
-- if (wwin->net_icon_image)
-- RReleaseImage(wwin->net_icon_image);
-- wwin->net_icon_image = new_rimage;
-+ len = data[best_pos-2] * data[best_pos-1];
-+ dst = new_rimage->data;
-+
-+ for (pos = best_pos; pos < best_pos + len; pos++, dst += 4) {
-+ src = (unsigned char *) &data[pos];
-+
-+#if BYTE_ORDER == BIG_ENDIAN
-+ src += sizeof(unsigned long) - 4;
-+ dst[0] = src[1]; /* R */
-+ dst[1] = src[2]; /* G */
-+ dst[2] = src[3]; /* B */
-+ dst[3] = src[0]; /* A */
-+#else /* Little endian */
-+ dst[0] = src[2]; /* R */
-+ dst[1] = src[1]; /* G */
-+ dst[2] = src[0]; /* B */
-+ dst[3] = src[3]; /* A */
-+#endif /* endianness */
-+ }
-+
-+ if (wwin->net_icon_image)
-+ RReleaseImage(wwin->net_icon_image);
-+ wwin->net_icon_image = new_rimage;
- }
-
- XFree(prop_return);
-@@ -426,7 +441,7 @@
- static void
- updateShowDesktop(WScreen * scr, Bool show)
- {
-- CARD32 foo;
-+ long foo;
-
- foo = (show == True);
- XChangeProperty(dpy, scr->root_win, net_showing_desktop, XA_CARDINAL, 32,
-@@ -599,7 +614,7 @@
- void
- wNETWMUpdateWorkarea(WScreen *scr, WArea usableArea)
- {
-- CARD32 *area;
-+ long *area;
- int count, i;
-
- /* XXX: not Xinerama compatible,
-@@ -609,7 +624,7 @@
- return;
-
- count = scr->workspace_count * 4;
-- area = wmalloc(sizeof(CARD32) * count);
-+ area = wmalloc(sizeof(long) * count);
- for (i=0; i<scr->workspace_count; i++) {
- area[4*i + 0] = usableArea.x1;
- area[4*i + 1] = usableArea.y1;
-@@ -732,7 +747,7 @@
- static void
- updateWorkspaceCount(WScreen *scr) /* changeable */
- {
-- CARD32 count;
-+ long count;
-
- count = scr->workspace_count;
-
-@@ -744,7 +759,7 @@
- static void
- updateCurrentWorkspace(WScreen *scr) /* changeable */
- {
-- CARD32 count;
-+ long count;
-
- count = scr->current_workspace;
-
-@@ -791,7 +806,7 @@
- static void
- updateWorkspaceHint(WWindow *wwin, Bool fake, Bool del)
- {
-- CARD32 l;
-+ long l;
-
- if (del) {
- XDeleteProperty(dpy, wwin->client_win, net_wm_desktop);
-Only in WindowMaker-0.91.0-test/src: wmspec.c.orig
diff --git a/x11-wm/windowmaker/files/0.91.0/maximize-fix-0.9x.patch b/x11-wm/windowmaker/files/0.91.0/maximize-fix-0.9x.patch
deleted file mode 100644
index 553b05c1ffb3..000000000000
--- a/x11-wm/windowmaker/files/0.91.0/maximize-fix-0.9x.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- WindowMaker-0.91.0/src/actions.c_old 2005-06-12 15:37:16.000000000 +0200
-+++ WindowMaker-0.91.0/src/actions.c 2005-06-12 15:38:44.000000000 +0200
-@@ -474,7 +474,7 @@
- void
- wUnmaximizeWindow(WWindow *wwin)
- {
-- int restore_x, restore_y;
-+ int x, y, w, h;
-
- if (!wwin->flags.maximized)
- return;
-@@ -483,13 +483,17 @@
- wwin->flags.skip_next_animation = 1;
- wUnshadeWindow(wwin);
- }
-- restore_x = (wwin->flags.maximized & MAX_HORIZONTAL) ?
-+ x = ((wwin->flags.maximized & MAX_HORIZONTAL) && wwin->old_geometry.x) ?
- wwin->old_geometry.x : wwin->frame_x;
-- restore_y = (wwin->flags.maximized & MAX_VERTICAL) ?
-+ y = ((wwin->flags.maximized & MAX_VERTICAL) && wwin->old_geometry.y) ?
- wwin->old_geometry.y : wwin->frame_y;
-+ w = wwin->old_geometry.width ?
-+ wwin->old_geometry.width : wwin->client.width;
-+ h = wwin->old_geometry.height ?
-+ wwin->old_geometry.height : wwin->client.height;
-+
- wwin->flags.maximized = 0;
-- wWindowConfigure(wwin, restore_x, restore_y,
-- wwin->old_geometry.width, wwin->old_geometry.height);
-+ wWindowConfigure(wwin, x, y, w, h);
-
- WMPostNotificationName(WMNChangedState, wwin, "maximize");
-
diff --git a/x11-wm/windowmaker/files/0.91.0/menufocus.patch b/x11-wm/windowmaker/files/0.91.0/menufocus.patch
deleted file mode 100644
index f913777bcb26..000000000000
--- a/x11-wm/windowmaker/files/0.91.0/menufocus.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -Naur ./WindowMaker-0.91.0/src/switchmenu.c WindowMaker-0.91.0.mod2/src/switchmenu.c
---- ./WindowMaker-0.91.0/src/switchmenu.c 2004-10-18 19:41:54.000000000 -0700
-+++ WindowMaker-0.91.0.mod2/src/switchmenu.c 2004-11-22 03:56:48.540567984 -0800
-@@ -231,7 +231,11 @@
- char *t;
- int idx;
-
-- if (wwin->flags.internal_window || WFLAGP(wwin, skip_window_list))
-+ if (wwin->flags.internal_window || WFLAGP(wwin, skip_window_list)
-+ || ((wwin->wm_gnustep_attr
-+ && wwin->wm_gnustep_attr->flags & GSWindowLevelAttr)
-+ && (wwin->wm_gnustep_attr->window_level == WMMainMenuWindowLevel
-+ || wwin->wm_gnustep_attr->window_level == WMSubmenuWindowLevel)))
- return;
-
- if (wwin->frame->title)
-diff -Naur ./WindowMaker-0.91.0/src/window.c WindowMaker-0.91.0.mod2/src/window.c
---- ./WindowMaker-0.91.0/src/window.c 2004-10-22 20:11:10.000000000 -0700
-+++ WindowMaker-0.91.0.mod2/src/window.c 2004-11-22 03:56:48.540567984 -0800
-@@ -340,17 +340,6 @@
- wwin->client_flags.no_appicon = 1;
- }
-
-- /* temporary solution to avoid GS menus in our window list.
-- * it's temporary because it's not the proper way: windows at the
-- * floating level are also skipped from the window list with this.
-- * Fix it -Dan */
-- if (gs_hints->flags & GSWindowLevelAttr) {
-- if (gs_hints->window_level == WMMainMenuWindowLevel ||
-- gs_hints->window_level == WMSubmenuWindowLevel) {
-- wwin->client_flags.skip_window_list = 1;
-- }
-- }
--
- }
-
-
diff --git a/x11-wm/windowmaker/files/digest-windowmaker-0.91.0-r1 b/x11-wm/windowmaker/files/digest-windowmaker-0.91.0-r1
deleted file mode 100644
index 966510ea620e..000000000000
--- a/x11-wm/windowmaker/files/digest-windowmaker-0.91.0-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 be07953e905d1e42fe7a65ac2193a5f9 WindowMaker-0.91.0.tar.gz 2742380
-RMD160 f593893d9aeba85fec42216f5f86a8c7c79db53e WindowMaker-0.91.0.tar.gz 2742380
-SHA256 464d91995f9b3f00ca266a06e785c06bb834dfae795fdff804922cf44a838d30 WindowMaker-0.91.0.tar.gz 2742380
-MD5 07c7700daaaf232bc490f5abaabef085 WindowMaker-extra-0.1.tar.gz 238018
-RMD160 94334c2c12d20a8fd0cd2a70e54cd3689f043038 WindowMaker-extra-0.1.tar.gz 238018
-SHA256 acd6e1fb790485b107daf2b710da372367b41383c55d9c8bdfdac521d850edc4 WindowMaker-extra-0.1.tar.gz 238018
diff --git a/x11-wm/windowmaker/windowmaker-0.91.0-r1.ebuild b/x11-wm/windowmaker/windowmaker-0.91.0-r1.ebuild
deleted file mode 100644
index 741412e21c00..000000000000
--- a/x11-wm/windowmaker/windowmaker-0.91.0-r1.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.91.0-r1.ebuild,v 1.24 2007/08/02 15:26:15 uberlord Exp $
-
-inherit eutils gnustep-funcs
-
-S=${WORKDIR}/${P/windowm/WindowM}
-
-DESCRIPTION="The fast and light GNUstep window manager"
-SRC_URI="ftp://ftp.windowmaker.info/pub/source/release/${P/windowm/WindowM}.tar.gz
- http://www.windowmaker.info/pub/source/release/WindowMaker-extra-0.1.tar.gz"
-HOMEPAGE="http://www.windowmaker.info/"
-
-IUSE="gif gnustep jpeg nls png tiff modelock xinerama"
-DEPEND="x11-libs/libXv
- x11-libs/libXft
- x11-libs/libXt
- media-libs/fontconfig
- gif? ( >=media-libs/giflib-4.1.0-r3 )
- png? ( >=media-libs/libpng-1.2.1 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- tiff? ( >=media-libs/tiff-3.6.1-r2 )"
-RDEPEND="${DEPEND}
- nls? ( >=sys-devel/gettext-0.10.39 )
- gnustep? ( gnustep-base/gnustep-env )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 mips ppc sparc x86 ~x86-fbsd"
-
-if use gnustep; then
- egnustep_install_domain "System"
-fi
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}/menufocus.patch || die "menu focus patch failed"
-}
-
-src_compile() {
- local myconf
- local gs_user_postfix
-
- # image format types
- # xpm is provided by X itself
- myconf="--enable-xpm $(use_enable png) $(use_enable jpeg) $(use_enable gif) $(use_enable tiff)"
-
- # non required X capabilities
- myconf="${myconf} $(use_enable modelock) $(use_enable xinerama)"
-
- # integrate with GNUstep environment, or not
- if use gnustep ; then
- egnustep_env
- myconf="${myconf} --with-appspath=$(egnustep_system_root)/Applications"
- else
- # no change from wm-0.80* ebuilds, as to not pollute things more
- myconf="${myconf} --with-appspath=/usr/lib/GNUstep/Applications"
- fi
-
- use nls \
- && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`" \
- || myconf="${myconf} --disable-nls --disable-locale"
-
- # default settings with $myconf appended
- econf \
- --sysconfdir=/etc/X11 \
- --with-x \
- --enable-usermenu \
- --with-pixmapdir=/usr/share/pixmaps \
- ${myconf} || die
-
- # don't know if zh_TW is still non-functional, but leaving it out still
- # for now
- cd ${S}/po
- cp Makefile Makefile.orig
- sed 's:zh_TW.*::' \
- Makefile.orig > Makefile
-
- cd ${S}/WPrefs.app/po
- cp Makefile Makefile.orig
- sed 's:zh_TW.*::' \
- Makefile.orig > Makefile
-
- cd ${S}
- for file in ${S}/WindowMaker/*menu*; do
- if [ -r $file ]; then
- if use gnustep ; then
- sed -e "s/\/usr\/local\/GNUstep/`cat ${TMP}/sed.gs_prefix`System/g;
- s/XXX_SED_FSLASH/\//g;" < $file > $file.tmp
- else
- sed -e 's/\/usr\/local\/GNUstep/\/usr\/lib\/GNUstep/g;' < $file > $file.tmp
- fi
- mv $file.tmp $file;
-
- sed -e 's/\/usr\/local\/share\/WindowMaker/\/usr\/share\/WindowMaker/g;' < $file > $file.tmp;
- mv $file.tmp $file;
- fi;
- done;
-
- cd ${S}
- emake -j1 || die "windowmaker: make has failed"
-
- cd ${S}
- for file in ${S}/WindowMaker/Defaults/W*; do
- if [ -r $file ]; then
- if use gnustep; then
- sed -e "s/\$HOME\/GNUstep\//\$HOME`cat ${TMP}/sed.gs_user_root_suffix`/g;
- s/XXX_SED_FSLASH/\//g;" < $file > $file.tmp
- mv $file.tmp $file;
-
- sed -e "s/~\/GNUstep\//~`cat ${TMP}/sed.gs_user_root_suffix`/g;
- s/XXX_SED_FSLASH/\//g;" < $file > $file.tmp
- mv $file.tmp $file;
- fi
- fi
- done;
-
- # WindowMaker Extra Package (themes and icons)
- cd ../WindowMaker-extra-0.1
- econf || die "windowmaker-extra: configure has failed"
- emake || die "windowmaker-extra: make has failed"
-}
-
-src_install() {
- emake install DESTDIR=${D} || die "windowmaker: install has failed."
-
- dodoc AUTHORS BUGFORM BUGS ChangeLog COPYING* INSTALL* FAQ* \
- MIRRORS README* NEWS TODO
-
- # WindowMaker Extra
- cd ../WindowMaker-extra-0.1
- emake install DESTDIR=${D} || die "windowmaker-extra: install failed"
-
- newdoc README README.extra
-
- # create wmaker session shell script
- echo "#!/bin/bash" > wmaker
- echo "/usr/bin/wmaker" >> wmaker
- exeinto /etc/X11/Sessions/
- doexe wmaker
-
- insinto /etc/X11/dm/Sessions
- doins ${FILESDIR}/wmaker.desktop
-}
-
-pkg_postinst() {
- einfo "If you are using 'startx' from the command line, and require"
- einfo " .xinitrc, you may need to execute 'wmaker.inst', which will"
- einfo " setup default configurations for you."
- einfo ""
-
- if use gnustep ; then
- einfo "WPrefs.app is installed in you GNUstep System Applications directory."
- einfo ""
- ewarn "*** IMPORTANT ***"
- ewarn "If you changed the GNUstep user root, via a use flag like 'layout-osx-like' in gnustep-make"
- ewarn " you will have to repair the personal WindowMaker config files you have. For example,"
- ewarn " if you changed the default user root as above, \$HOME/GNUstep to ~/, these commands"
- ewarn " will help you:"
- ewarn "cd ; cp -a ./GNUstep/.AppInfo . ; cp -a ./GNUstep/Defaults/W* ./Defaults/ ;"
- ewarn " cp -a ./GNUstep/Library/Icons ./GNUstep/Library/WindowMaker ./Library/"
- ewarn "The above commands are specifically to help repair your WindowMaker install;"
- ewarn " a less elegant, but reasonable method is to simply run wmaker.inst again,"
- ewarn " **after sourcing GNUstep.sh**, as this env script sets the GNUSTEP_USER_ROOT variable."
- ewarn "Generally, other config files in your old ~/GNUstep directory, can simply be"
- ewarn " moved to the new GNUSTEP_USER_ROOT."
- ewarn "^^^ IMPORTANT ^^^"
- ewarn ""
- else
- einfo "Even though you are not using the GNUstep environment, wmaker.inst will"
- einfo " create a 'GNUstep' directory in your home -- it uses this directory"
- einfo " to store your WindowMaker configuration files."
- einfo "WPrefs.app can be launched at /usr/lib/GNUstep/Applications/WPrefs.app/WPrefs"
- einfo " or by simply **clicking on it in the WindowMaker default dock.**"
- einfo ""
- fi
-
- ewarn "This package provides libwraster.so.3. Packages depending on"
- ewarn " libwraster.so.2 will have to be rebuilt, i.e. 'revdep-rebuild'"
-
- ebeep 4
- epause 4
-}