summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-09 06:45:57 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-09 06:45:57 +0000
commit41fa096a208903873bb6ec79347495aa0bb83aec (patch)
treeb9477eea7ac78ab2182c20cb97526ffe7bd495ac /x11-wm
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-41fa096a208903873bb6ec79347495aa0bb83aec.tar.gz
gentoo-2-41fa096a208903873bb6ec79347495aa0bb83aec.tar.bz2
gentoo-2-41fa096a208903873bb6ec79347495aa0bb83aec.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/ChangeLog8
-rw-r--r--x11-wm/enlightenment/enlightenment-0.16.9999.ebuild7
-rw-r--r--x11-wm/enlightenment/enlightenment-1.0.4.ebuild83
3 files changed, 94 insertions, 4 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 934fb829884d..ae5c59e09ae2 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.135 2010/08/03 02:58:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.136 2010/08/09 06:45:57 vapier Exp $
+
+*enlightenment-1.0.4 (09 Aug 2010)
+
+ 09 Aug 2010; Mike Frysinger <vapier@gentoo.org>
+ enlightenment-0.16.9999.ebuild, +enlightenment-1.0.4.ebuild:
+ Version bump.
03 Aug 2010; Jeroen Roovers <jer@gentoo.org> enlightenment-1.0.2.ebuild:
Stable for HPPA (bug #330573).
diff --git a/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild b/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild
index c73a171ef949..8aafed122ccc 100644
--- a/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild
+++ b/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild,v 1.35 2010/05/07 23:45:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.16.9999.ebuild,v 1.36 2010/08/09 06:45:57 vapier Exp $
EAPI="2"
if [[ ${PV} == *9999 ]] ; then
@@ -21,7 +21,7 @@ HOMEPAGE="http://www.enlightenment.org/"
LICENSE="BSD"
SLOT="0"
-IUSE="doc dbus esd nls pango pulseaudio xcomposite xinerama xrandr"
+IUSE="dbus doc esd nls pango pulseaudio xcomposite xinerama xrandr"
RDEPEND="esd? ( >=media-sound/esound-0.2.19 )
pulseaudio? ( media-sound/pulseaudio )
@@ -78,5 +78,6 @@ src_configure() {
src_install() {
emake install DESTDIR="${D}" || die
rmdir "${D}"/usr/share/doc/e16 || die #294456
- dodoc AUTHORS ChangeLog COMPLIANCE TODO
+ dodoc AUTHORS ChangeLog COMPLIANCE TODO sample-scripts/*
+ dohtml docs/e16.html
}
diff --git a/x11-wm/enlightenment/enlightenment-1.0.4.ebuild b/x11-wm/enlightenment/enlightenment-1.0.4.ebuild
new file mode 100644
index 000000000000..1357816259fa
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-1.0.4.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-1.0.4.ebuild,v 1.1 2010/08/09 06:45:57 vapier Exp $
+
+EAPI="2"
+if [[ ${PV} == *9999 ]] ; then
+ ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/E16/e"
+ inherit subversion autotools
+ SRC_URI=""
+ #KEYWORDS=""
+ S=${WORKDIR}/e16/e
+else
+ SRC_URI="mirror://sourceforge/enlightenment/e16-${PV/_/-}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+ S=${WORKDIR}/e16-${PV/_pre?}
+fi
+inherit eutils
+
+DESCRIPTION="Enlightenment Window Manager"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="dbus doc esd nls pango pulseaudio xcomposite xinerama xrandr"
+
+RDEPEND="esd? ( >=media-sound/esound-0.2.19 )
+ pulseaudio? ( media-sound/pulseaudio )
+ dbus? ( sys-apps/dbus )
+ pango? ( x11-libs/pango )
+ =media-libs/freetype-2*
+ >=media-libs/imlib2-1.3.0[X]
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXxf86vm
+ x11-libs/libXft
+ xrandr? ( x11-libs/libXrandr )
+ x11-libs/libXrender
+ x11-misc/xbitmaps
+ xinerama? ( x11-libs/libXinerama )
+ xcomposite? ( x11-libs/libXcomposite )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ xcomposite? ( x11-proto/compositeproto )
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( app-doc/edox-data )"
+
+src_prepare() {
+ if [[ ! -e configure ]] ; then
+ eautopoint
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable pulseaudio sound-pulse) \
+ $(use_enable esd sound-esound) \
+ $(use_enable pango) \
+ $(use_enable xinerama) \
+ $(use_enable xrandr) \
+ $(use_enable xcomposite composite) \
+ --disable-docs \
+ --enable-zoom
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ rmdir "${D}"/usr/share/doc/e16 || die #294456
+ dodoc AUTHORS ChangeLog COMPLIANCE TODO sample-scripts/*
+ dohtml docs/e16.html
+}