summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-06 12:19:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-06 12:19:45 +0000
commit39baa17fdff8055bb573135ece81c6a7b258fe30 (patch)
tree104fa5f09801957c0c748d72ca0eebc8f389133e /x11-wm
parentPass -Wl,--no-as-needed with USE="openmp" and <sys-devel/libtool-2.4-r2 wrt #... (diff)
downloadgentoo-2-39baa17fdff8055bb573135ece81c6a7b258fe30.tar.gz
gentoo-2-39baa17fdff8055bb573135ece81c6a7b258fe30.tar.bz2
gentoo-2-39baa17fdff8055bb573135ece81c6a7b258fe30.zip
Fix building with libpng15 wrt #385851 by "Zosiek"
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog8
-rw-r--r--x11-wm/afterstep/afterstep-2.2.9.ebuild18
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch31
3 files changed, 47 insertions, 10 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 4dcc85abc51b..ffe3c0c4a4b5 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/afterstep
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.97 2010/11/08 13:43:13 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.98 2011/10/06 12:19:45 ssuominen Exp $
+
+ 06 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> afterstep-2.2.9.ebuild,
+ +files/afterstep-2.2.9-libpng15.patch:
+ Fix building with libpng15 wrt #385851 by "Zosiek"
08 Nov 2010; Bernard Cafarelli <voyageur@gentoo.org>
afterstep-2.2.9.ebuild:
diff --git a/x11-wm/afterstep/afterstep-2.2.9.ebuild b/x11-wm/afterstep/afterstep-2.2.9.ebuild
index deef0f448890..b7b7cd45bafc 100644
--- a/x11-wm/afterstep/afterstep-2.2.9.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.16 2010/11/08 13:43:13 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.17 2011/10/06 12:19:45 ssuominen Exp $
-EAPI=2
+EAPI=4
inherit autotools flag-o-matic eutils
DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
@@ -43,10 +43,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/AfterStep-${PV}
src_prepare() {
- epatch "${FILESDIR}"/no-alternatives-${PV}.patch \
+ epatch \
+ "${FILESDIR}"/no-alternatives-${PV}.patch \
"${FILESDIR}"/${P}-make_session_data_file.patch \
"${FILESDIR}"/${P}-alpha.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
sed -i \
-e '/CFLAGS="-O3"/d' \
@@ -69,7 +71,7 @@ src_prepare() {
src_compile() {
# gcc: ../libAfterConf/libAfterConf.a: No such file or directory
# make[1]: *** [PrintDesktopEntries] Error 1
- emake -j1 || die
+ emake -j1
}
src_configure() {
@@ -105,11 +107,11 @@ src_configure() {
--disable-availability \
--disable-staticlibs \
--enable-ascp=no \
- ${myconf} || die "configure failed"
+ ${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
# Create a symlink from MonitorWharf to Wharf
rm "${D}"/usr/bin/MonitorWharf
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch b/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch
new file mode 100644
index 000000000000..b420489b3266
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch
@@ -0,0 +1,31 @@
+--- libAfterImage/export.c
++++ libAfterImage/export.c
+@@ -483,7 +483,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- libAfterImage/import.c
++++ libAfterImage/import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }