summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-02-18 15:37:05 +0000
committerMichael Weber <xmw@gentoo.org>2011-02-18 15:37:05 +0000
commit36e74537ceb0b5145ca4124ad268579e978a9cad (patch)
treef733b903c2975fab186df74cfe7a2195101a133f /x11-wm
parentVersion bump, dropped sparc and hppa because of qt-webkit dependency (diff)
downloadgentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.tar.gz
gentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.tar.bz2
gentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/cwm/ChangeLog11
-rw-r--r--x11-wm/cwm/cwm-20110213.ebuild38
-rw-r--r--x11-wm/cwm/cwm-99999999.ebuild42
-rw-r--r--x11-wm/cwm/files/cwm-20110213-Makefile.patch35
4 files changed, 124 insertions, 2 deletions
diff --git a/x11-wm/cwm/ChangeLog b/x11-wm/cwm/ChangeLog
index 8cb725127359..9957dcb6822e 100644
--- a/x11-wm/cwm/ChangeLog
+++ b/x11-wm/cwm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/cwm
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.8 2010/11/21 19:37:03 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.9 2011/02/18 15:37:05 xmw Exp $
+
+*cwm-99999999 (18 Feb 2011)
+*cwm-20110213 (18 Feb 2011)
+
+ 18 Feb 2011; Michael Weber <xmw@gentoo.org> +cwm-20110213.ebuild,
+ +files/cwm-20110213-Makefile.patch, +cwm-99999999.ebuild:
+ Version bump
21 Nov 2010; Michael Weber <xmw@gentoo.org> cwm-20100930.ebuild:
Added ~arm and ~sparc keyword
diff --git a/x11-wm/cwm/cwm-20110213.ebuild b/x11-wm/cwm/cwm-20110213.ebuild
new file mode 100644
index 000000000000..614fb0c6447c
--- /dev/null
+++ b/x11-wm/cwm/cwm-20110213.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-20110213.ebuild,v 1.1 2011/02/18 15:37:05 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ https://github.com/chneukirchen/cwm.git"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ export LDADD="${LDFLAGS}"
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/x11-wm/cwm/cwm-99999999.ebuild b/x11-wm/cwm/cwm-99999999.ebuild
new file mode 100644
index 000000000000..4048b825bd1d
--- /dev/null
+++ b/x11-wm/cwm/cwm-99999999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-99999999.ebuild,v 1.1 2011/02/18 15:37:05 xmw Exp $
+
+EAPI=2
+
+EGIT_REPO_URI=https://github.com/chneukirchen/cwm.git
+EGIT_BRANCH=linux
+
+inherit eutils toolchain-funcs git
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ https://github.com/chneukirchen/cwm.git"
+SRC_URI=""
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110213-Makefile.patch
+}
+
+src_compile() {
+ export LDADD="${LDFLAGS}"
+ #export YACC=""
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/x11-wm/cwm/files/cwm-20110213-Makefile.patch b/x11-wm/cwm/files/cwm-20110213-Makefile.patch
new file mode 100644
index 000000000000..c47ecd4225e2
--- /dev/null
+++ b/x11-wm/cwm/files/cwm-20110213-Makefile.patch
@@ -0,0 +1,35 @@
+--- cwm-20110213/Makefile.orig
++++ cwm-20110213/Makefile
+@@ -15,16 +15,14 @@
+ kbfunc.o mousefunc.o font.o strlcpy.o strlcat.o y.tab.o \
+ strtonum.o fgetln.o
+
+-X11BASE= /usr
+-
+-CPPFLAGS+= -I${X11BASE}/include -I${X11BASE}/include/freetype2 -I.
++CPPFLAGS+= $(shell pkg-config --cflags-only-I xft)
+
+-CFLAGS+= -Wall -O2 -g
++CFLAGS+=
+
+ LDADD+= -L${X11BASE}/lib -lXft -lXrender -lX11 ${LIBXCB} -lXau -lXdmcp \
+ -lfontconfig -lexpat -lfreetype -lz -lXinerama -lXrandr -lXext
+
+-MANDIR= ${X11BASE}/man/cat
++MANDIR= /usr/share/man
+ MAN= cwm.1 cwmrc.5
+
+ CLEANFILES= cwm.cat1 cwmrc.cat5
+@@ -46,9 +45,9 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $<
+
+ install: ${PROG}
+- install -m 755 cwm /usr/local/bin/
+- install -m 644 cwm.1 /usr/local/man/man1
+- install -m 644 cwmrc.5 /usr/local/man/man5
++ install -D -m 755 cwm $(DESTDIR)$(BINDIR)/cwm
++ install -D -m 644 cwm.1 $(DESTDIR)$(MANDIR)/man1/cwm.1
++ install -D -m 644 cwmrc.5 $(DESTDIR)$(MANDIR)/man5/cwmrc.5
+
+ #.include <bsd.prog.mk>
+ #.include <bsd.xorg.mk>