summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-08-19 18:44:27 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-08-19 18:44:27 +0000
commit8c1e00733365d53582c8dc20dac4f60e4fa626f6 (patch)
tree5cc5ef75082bea8a6466aed09a23c25938d1f379 /x11-wm/oroborus/oroborus-2.0.7.ebuild
parentnew version. close #6397. (diff)
downloadgentoo-2-8c1e00733365d53582c8dc20dac4f60e4fa626f6.tar.gz
gentoo-2-8c1e00733365d53582c8dc20dac4f60e4fa626f6.tar.bz2
gentoo-2-8c1e00733365d53582c8dc20dac4f60e4fa626f6.zip
new version of x11-wm/oroborus
Diffstat (limited to 'x11-wm/oroborus/oroborus-2.0.7.ebuild')
-rw-r--r--x11-wm/oroborus/oroborus-2.0.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/oroborus/oroborus-2.0.7.ebuild b/x11-wm/oroborus/oroborus-2.0.7.ebuild
new file mode 100644
index 000000000000..c85d94264648
--- /dev/null
+++ b/x11-wm/oroborus/oroborus-2.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/oroborus/oroborus-2.0.7.ebuild,v 1.1 2002/08/19 18:44:23 blizzy Exp $
+
+DESCRIPTION="Small and fast window manager."
+HOMEPAGE="http://www.dreamind.de/oroborus.shtml"
+SRC_URI="http://www.dreamind.de/debian/dists/sid/main/source/x11/${P/-/_}-1.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/oroborus \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/oroborus \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ if [ "`use gnome`" ] ; then
+
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/oroborus.desktop
+ fi
+
+ dodoc README INSTALL ChangeLog TODO NEWS AUTHORS example.oroborusrc
+}