summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-06-04 21:42:08 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-06-04 21:42:08 +0000
commit7568a42ebc2918a924ac067c7ecaa94005be7001 (patch)
treed7528578acd120a1c5234882ab4d5de0a640fc31 /x11-wm/matchbox-panel
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-7568a42ebc2918a924ac067c7ecaa94005be7001.tar.gz
gentoo-2-7568a42ebc2918a924ac067c7ecaa94005be7001.tar.bz2
gentoo-2-7568a42ebc2918a924ac067c7ecaa94005be7001.zip
Version dump.
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'x11-wm/matchbox-panel')
-rw-r--r--x11-wm/matchbox-panel/ChangeLog7
-rw-r--r--x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.33
-rw-r--r--x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/x11-wm/matchbox-panel/ChangeLog b/x11-wm/matchbox-panel/ChangeLog
index b4cd5c0fb4ce..8db2f70e1bb9 100644
--- a/x11-wm/matchbox-panel/ChangeLog
+++ b/x11-wm/matchbox-panel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/matchbox-panel
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/ChangeLog,v 1.2 2006/04/28 00:04:20 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/ChangeLog,v 1.3 2006/06/04 21:42:08 yvasilev Exp $
+
+*matchbox-panel-0.9.3 (04 Jun 2006)
+
+ 04 Jun 2006; <yvasilev@gentoo.org> +matchbox-panel-0.9.3.ebuild:
+ Version dump.
28 Apr 2006; Marien Zwart <marienz@gentoo.org> Manifest:
Fixing SHA256 digest, pass four
diff --git a/x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.3 b/x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.3
new file mode 100644
index 000000000000..208c23c0a9a9
--- /dev/null
+++ b/x11-wm/matchbox-panel/files/digest-matchbox-panel-0.9.3
@@ -0,0 +1,3 @@
+MD5 56d1807636f3919e22e51896ab7ccd2e matchbox-panel-0.9.3.tar.bz2 162477
+RMD160 6a91d010c75b3eed1c0b0af79d48e5d41d5a4af2 matchbox-panel-0.9.3.tar.bz2 162477
+SHA256 319b656e2f1f25339d65802a3136f31169141fd54d1ca9131ff4aada62b25ce6 matchbox-panel-0.9.3.tar.bz2 162477
diff --git a/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild b/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
new file mode 100644
index 000000000000..08e9e4b3efd3
--- /dev/null
+++ b/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-panel/matchbox-panel-0.9.3.ebuild,v 1.1 2006/06/04 21:42:08 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="The Matchbox Panel"
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="acpi debug dnotify lowres nls startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ startup-notification? ( x11-libs/startup-notification )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-common"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable startup-notification) \
+ $(use_enable dnotify) \
+ $(use_enable acpi acpi-linux) \
+ $(use_enable lowres small-icons) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}