summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2009-02-08 23:08:38 +0000
committerCédric Krier <cedk@gentoo.org>2009-02-08 23:08:38 +0000
commite182775cc08201692371f69161a26ed97a8e7c38 (patch)
tree1314b3b983b84fd771bfdba7a0ad05a8660bb125 /x11-wm/dwm
parent Invalid aRts dependency, proper desktop file fix, missing eclass function ca... (diff)
downloadgentoo-2-e182775cc08201692371f69161a26ed97a8e7c38.tar.gz
gentoo-2-e182775cc08201692371f69161a26ed97a8e7c38.tar.bz2
gentoo-2-e182775cc08201692371f69161a26ed97a8e7c38.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-hardened-r3 i686)
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/ChangeLog10
-rw-r--r--x11-wm/dwm/dwm-5.4.1.ebuild80
-rw-r--r--x11-wm/dwm/files/dwm-session211
3 files changed, 99 insertions, 2 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 7c9908451e18..6e4ee9501fe3 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/dwm
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.52 2008/12/21 12:34:39 cedk Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.53 2009/02/08 23:08:38 cedk Exp $
+
+*dwm-5.4.1 (08 Feb 2009)
+
+ 08 Feb 2009; Cédric Krier <cedk@gentoo.org> +files/dwm-session2,
+ +dwm-5.4.1.ebuild:
+ Version bump
*dwm-5.3.1 (21 Dec 2008)
diff --git a/x11-wm/dwm/dwm-5.4.1.ebuild b/x11-wm/dwm/dwm-5.4.1.ebuild
new file mode 100644
index 000000000000..f423a9df0470
--- /dev/null
+++ b/x11-wm/dwm/dwm-5.4.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-5.4.1.ebuild,v 1.1 2009/02/08 23:08:38 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://www.suckless.org/dwm/"
+SRC_URI="http://code.suckless.org/dl/dwm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? (
+ x11-proto/xineramaproto
+ x11-libs/libXinerama
+ )"
+RDEPEND="${DEPEND}
+ x11-apps/xsetroot"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed${msg}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+ einfo "Since dwm-5.4, status info in the bar must be set like this:"
+ einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
+}
diff --git a/x11-wm/dwm/files/dwm-session2 b/x11-wm/dwm/files/dwm-session2
new file mode 100644
index 000000000000..bbf1cfd83a3f
--- /dev/null
+++ b/x11-wm/dwm/files/dwm-session2
@@ -0,0 +1,11 @@
+#!/bin/sh
+DIR=${HOME}/.dwm
+if [ -f "${DIR}"/dwmrc ]; then
+ /bin/sh "${DIR}"/dwmrc &
+else
+ (while true; do
+ echo `date`
+ sleep 1
+ done)&
+fi
+exec /usr/bin/dwm