summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-13 14:01:48 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-13 14:01:48 +0000
commit06902e180932a35149d901f1ea94aa5c451d4d46 (patch)
tree486167be6fd8ade3da25bdd481d13716e3894802 /x11-wm/dwm
parentBump to version 1.5; thanks to Christian Schlotter; bug 125492 (diff)
downloadgentoo-2-06902e180932a35149d901f1ea94aa5c451d4d46.tar.gz
gentoo-2-06902e180932a35149d901f1ea94aa5c451d4d46.tar.bz2
gentoo-2-06902e180932a35149d901f1ea94aa5c451d4d46.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/ChangeLog7
-rw-r--r--x11-wm/dwm/dwm-3.0.ebuild93
-rw-r--r--x11-wm/dwm/files/digest-dwm-3.03
3 files changed, 102 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index d57bac5906db..bc137f859f72 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.3 2007/01/09 20:21:52 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.4 2007/01/13 14:01:48 cedk Exp $
+
+*dwm-3.0 (13 Jan 2007)
+
+ 13 Jan 2007; Cedric Krier <cedk@gentoo.org> +dwm-3.0.ebuild:
+ Version bump
*dwm-2.9 (09 Jan 2007)
diff --git a/x11-wm/dwm/dwm-3.0.ebuild b/x11-wm/dwm/dwm-3.0.ebuild
new file mode 100644
index 000000000000..e49fc145a307
--- /dev/null
+++ b/x11-wm/dwm/dwm-3.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-3.0.ebuild,v 1.1 2007/01/13 14:01:48 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ [[ -r config.h ]] && rm config.h
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp ${configfile} "${S}"/config.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-3.0 b/x11-wm/dwm/files/digest-dwm-3.0
new file mode 100644
index 000000000000..f1384d1bfb75
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-3.0
@@ -0,0 +1,3 @@
+MD5 d22a8c551e0b20d12cd05bf4d16d5a8b dwm-3.0.tar.gz 18049
+RMD160 c402492c105f94d854c99230a16b13965b21b158 dwm-3.0.tar.gz 18049
+SHA256 70c25d40b8cf3d4b160f50b84af0b5ec2ea32710a76b1847249e17f7d8e2202c dwm-3.0.tar.gz 18049