summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-21 12:22:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-21 12:22:43 +0000
commit9796d0353888cd033e8a528f36ccff6e07e7edcf (patch)
treea5e48541f36658979ea5f47a29d6b1eef73cb716 /x11-themes
parentadd ~arm, bug #411761 (diff)
downloadgentoo-2-9796d0353888cd033e8a528f36ccff6e07e7edcf.tar.gz
gentoo-2-9796d0353888cd033e8a528f36ccff6e07e7edcf.tar.bz2
gentoo-2-9796d0353888cd033e8a528f36ccff6e07e7edcf.zip
Version bump. GTK+-3.4 compability
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-unico/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.2.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-unico/ChangeLog b/x11-themes/gtk-engines-unico/ChangeLog
index c8e582250888..9168635934af 100644
--- a/x11-themes/gtk-engines-unico/ChangeLog
+++ b/x11-themes/gtk-engines-unico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-unico
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-unico/ChangeLog,v 1.3 2012/03/21 06:23:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-unico/ChangeLog,v 1.4 2012/04/21 12:22:43 ssuominen Exp $
+
+*gtk-engines-unico-1.0.2 (21 Apr 2012)
+
+ 21 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +gtk-engines-unico-1.0.2.ebuild:
+ Version bump.
21 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
gtk-engines-unico-1.0.1.ebuild:
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.2.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.2.ebuild
new file mode 100644
index 000000000000..bb634dd6cd0b
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.2.ebuild,v 1.1 2012/04/21 12:22:43 ssuominen Exp $
+
+EAPI=4
+
+MY_PN=${PN/gtk-engines-}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The Unico GTK+ 3.x Theming Engine"
+HOMEPAGE="https://launchpad.net/unico"
+SRC_URI="https://launchpad.net/${MY_PN}/${PV%.*}/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26
+ >=x11-libs/cairo-1.10[glib]
+ >=x11-libs/gtk+-3.3.14:3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS" # ChangeLog and README are empty.
+}
+
+src_configure() {
+ # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
+ # unused in the code itself.
+ econf \
+ --disable-static \
+ --disable-debug \
+ --disable-maintainer-flags
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}