summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-19 13:14:24 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-19 13:14:24 +0000
commitf1ae13589e2e019d1746da71bff670bba857b7bb (patch)
tree80c46f70be3b5e3f9ddcac557bafa8f0e5a11861 /x11-themes/fvwm-crystal
parentAdd kde/systemd variants too (#481920#c20) (diff)
downloadgentoo-2-f1ae13589e2e019d1746da71bff670bba857b7bb.tar.gz
gentoo-2-f1ae13589e2e019d1746da71bff670bba857b7bb.tar.bz2
gentoo-2-f1ae13589e2e019d1746da71bff670bba857b7bb.zip
Version bump. Bug #477828
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'x11-themes/fvwm-crystal')
-rw-r--r--x11-themes/fvwm-crystal/ChangeLog7
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-themes/fvwm-crystal/ChangeLog b/x11-themes/fvwm-crystal/ChangeLog
index 53674e563fa3..36d1778903cf 100644
--- a/x11-themes/fvwm-crystal/ChangeLog
+++ b/x11-themes/fvwm-crystal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/fvwm-crystal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.73 2013/06/23 10:00:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/ChangeLog,v 1.74 2013/10/19 13:14:24 hwoarang Exp $
+
+*fvwm-crystal-3.2.5 (19 Oct 2013)
+
+ 19 Oct 2013; Markos Chandras <hwoarang@gentoo.org> +fvwm-crystal-3.2.5.ebuild:
+ Version bump. Bug #477828
*fvwm-crystal-3.2.3 (23 Jun 2013)
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild
new file mode 100644
index 000000000000..f329e76c5cec
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.2.5.ebuild,v 1.1 2013/10/19 13:14:24 hwoarang Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+}
+
+pkg_postinst() {
+ einfo
+ einfo "After installation, execute following commands:"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources"
+ einfo " $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc"
+ einfo
+ einfo "Many applications can extend functionality of fvwm-crystal."
+ einfo "They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo
+ einfo "Some icons fixes was committed recently."
+ einfo "To archive the same fixes on your private icon files,"
+ einfo "please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz."
+ einfo "This will fix the libpng warnings at stderr."
+ einfo
+ einfo "The color themes was updated to Fvwm InfoStore."
+ einfo "To know how to update your custom color themes, please run"
+ einfo " ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+ einfo ""
+}