summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-28 12:18:35 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-28 12:18:35 +0000
commitec1bbf2b11055e35994ffe41363f5f68102868e7 (patch)
tree705ef4c26ceffad9b4bd68c4827c2a1277029ac5 /x11-terms
parentadded rxvt-unicode terminfo generation wrt bug #192083 (diff)
downloadgentoo-2-ec1bbf2b11055e35994ffe41363f5f68102868e7.tar.gz
gentoo-2-ec1bbf2b11055e35994ffe41363f5f68102868e7.tar.bz2
gentoo-2-ec1bbf2b11055e35994ffe41363f5f68102868e7.zip
moved terminfo generation to ncurses wrt bug #192083
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.06-r3.ebuild124
2 files changed, 131 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 0759ef3f7407..a179bc7a951f 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.140 2009/10/26 21:20:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.141 2009/10/28 12:18:35 wired Exp $
+
+*rxvt-unicode-9.06-r3 (28 Oct 2009)
+
+ 28 Oct 2009; Alex Alexander <wired@gentoo.org>
+ +rxvt-unicode-9.06-r3.ebuild:
+ moved terminfo generation to ncurses wrt bug #192083
26 Oct 2009; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Add vostorga too.
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.06-r3.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.06-r3.ebuild
new file mode 100644
index 000000000000..6a6861965e35
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.06-r3.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.06-r3.ebuild,v 1.1 2009/10/28 12:18:35 wired Exp $
+
+EAPI="2"
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755 afterimage xterm-color wcwidth +vanilla"
+
+# see bug #115992 for modular x deps
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft
+ afterimage? ( media-libs/libafterimage )
+ x11-libs/libXrender
+ perl? ( dev-lang/perl )
+ >=sys-libs/ncurses-5.7-r3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ #Bug 270694
+ epatch "${FILESDIR}/${PN}-9.06-glibc-2.10.patch"
+
+ if (use xterm-color || use wcwidth); then
+ ewarn "You enabled xterm-color or wcwidth or both."
+ ewarn "Please note that neither of them are supported by upstream."
+ ewarn "You are at your own if you run into problems."
+ ebeep 5
+ fi
+
+ local tdir=/usr/share/terminfo
+ if use xterm-color; then
+ epatch doc/urxvt-8.2-256color.patch
+ sed -e \
+ 's/^\(rxvt-unicode\)/\1256/;s/colors#88/colors#256/;s/pairs#256/pairs#32767/' \
+ doc/etc/rxvt-unicode.terminfo > doc/etc/rxvt-unicode256.terminfo
+ sed -i -e \
+ "s~^\(\s\+@TIC@.*\)~\1\n\t@TIC@ -o "${D}"/${tdir} \$(srcdir)/etc/rxvt-unicode256.terminfo~" \
+ doc/Makefile.in
+ fi
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in ||
+ die "sed failed"
+
+ use wcwidth && epatch doc/wcwidth.patch
+
+ # bug #240165
+ epatch "${FILESDIR}"/${P}-no-urgency-if-focused.diff
+
+ # ncurses will provide rxvt-unicode terminfo, so we don't install them again
+ # see bug #192083
+ #
+ # According to my tests this is not (yet?) true, so keep it prepared and
+ # disabled until it's needed again.
+ #if has_version '<sys-libs/ncurses-5.7'; then
+ sed -i -e \
+ "s~@TIC@ \(\$(srcdir)/etc/rxvt\)~@TIC@ -o "${D}"/${tdir} \1~" \
+ doc/Makefile.in
+ #else
+ # # Remove everything except if we have rxvt-unicode256
+ # sed -i -e \
+ # '/rxvt-unicode256/p;/@TIC@/d' \
+ # doc/Makefile.in
+ #fi
+
+ # bug #263638
+ epatch "${FILESDIR}"/${P}-popups-hangs.patch
+
+ # bug #237271
+ if ! use vanilla; then
+ ewarn "You are going to include third-party bug fixes/features."
+ ewarn "They came without any warranty and are not supported by the"
+ ewarn "Gentoo community."
+ ebeep 5
+ epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+ use xterm-color && myconf="$myconf --enable-xterm-colors=256"
+
+ econf --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable afterimage) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}