summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-08 22:17:02 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-08 22:17:02 +0000
commitab56f9a5c83327f189f7874323bf2166a1db0f44 (patch)
tree6de952c55a5893a76ab23ca3ad1847fc2d0cf58b /x11-terms
parentremove unused Palm-SDK license (diff)
downloadgentoo-2-ab56f9a5c83327f189f7874323bf2166a1db0f44.tar.gz
gentoo-2-ab56f9a5c83327f189f7874323bf2166a1db0f44.tar.bz2
gentoo-2-ab56f9a5c83327f189f7874323bf2166a1db0f44.zip
Version bump, see bug #237260.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mrxvt/ChangeLog11
-rw-r--r--x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch13
-rw-r--r--x11-terms/mrxvt/mrxvt-0.5.4.ebuild121
3 files changed, 143 insertions, 2 deletions
diff --git a/x11-terms/mrxvt/ChangeLog b/x11-terms/mrxvt/ChangeLog
index e27fb95afee3..600d445c592c 100644
--- a/x11-terms/mrxvt/ChangeLog
+++ b/x11-terms/mrxvt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-terms/mrxvt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.68 2008/08/21 22:29:14 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.69 2009/01/08 22:17:02 nelchael Exp $
+
+*mrxvt-0.5.4 (08 Jan 2009)
+
+ 08 Jan 2009; <nelchael@gentoo.org>
+ +files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch,
+ +mrxvt-0.5.4.ebuild:
+ Version bump, see bug #237260.
21 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
new file mode 100644
index 000000000000..a52a10269bc1
--- /dev/null
+++ b/x11-terms/mrxvt/files/mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch
@@ -0,0 +1,13 @@
+Index: src/tabbar.c
+===================================================================
+--- src/tabbar.c (revision 337)
++++ src/tabbar.c (working copy)
+@@ -1327,7 +1327,7 @@
+ if( p.we_wordc > 1)
+ rxvt_msg( DBG_ERROR, DBG_TABBAR,
+ "Too many words when expanding %s\n", cwdOption );
+- else
++ else if( NOT_NULL( *p.we_wordv ) )
+ {
+ filename = *p.we_wordv;
+
diff --git a/x11-terms/mrxvt/mrxvt-0.5.4.ebuild b/x11-terms/mrxvt/mrxvt-0.5.4.ebuild
new file mode 100644
index 000000000000..9585b1948e29
--- /dev/null
+++ b/x11-terms/mrxvt/mrxvt-0.5.4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/mrxvt-0.5.4.ebuild,v 1.1 2009/01/08 22:17:02 nelchael Exp $
+
+inherit eutils
+
+DESCRIPTION="Multi-tabbed rxvt clone with XFT, transparent background and CJK support"
+HOMEPAGE="http://materm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/materm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~x86"
+
+LINGUAS_IUSE="linguas_el linguas_ja linguas_ko linguas_th linguas_zh_CN linguas_zh_TW"
+IUSE="debug png jpeg session truetype menubar utempter xpm ${LINGUAS_IUSE}"
+
+RDEPEND="png? ( media-libs/libpng )
+ utempter? ( sys-libs/libutempter )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( virtual/xft
+ media-libs/fontconfig
+ media-libs/freetype )
+ x11-libs/libX11
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )
+ x11-libs/libXrender"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-001-fix-segfault-when-wd-empty.patch"
+
+}
+
+src_compile() {
+
+ local myconf
+
+ # if you want to pass any other flags, use EXTRA_ECONF.
+ if use linguas_el ; then
+ myconf="${myconf} --enable-greek"
+ fi
+ if use linguas_ja ; then
+ # --with-encoding=sjis
+ myconf="${myconf} --enable-kanji --with-encoding=eucj"
+ fi
+ if use linguas_ko ; then
+ myconf="${myconf} --enable-kr --with-encoding=kr"
+ fi
+ if use linguas_th ; then
+ myconf="${myconf} --enable-thai"
+ fi
+ if use linguas_zh_CN ; then
+ # --with-encoding=gbk
+ myconf="${myconf} --enable-gb --with-encoding=gb"
+ fi
+ if use linguas_zh_TW ; then
+ myconf="${myconf} --enable-big5 --with-encoding=big5"
+ fi
+
+ # 2006-03-13 gi1242: mrxvt works best with TERM=rxvt AND correctly set
+ # termcap / terminfo entries. If the rxvt termcap / terminfo entries are
+ # messed up then then it's better to set TERM=xterm.
+ #
+ # Provide support for this by setting the or RXVT_TERM environment variables
+ # before emerging, as done in the rxvt ebuild.
+
+ if [[ -n ${RXVT_TERM} ]]; then
+ myconf="${myconf} --with-term=${RXVT_TERM}"
+ fi
+
+ econf \
+ --enable-everything \
+ --with-atab-extra=25 \
+ $(use_enable debug) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xpm) \
+ $(use_enable session sessionmgr) \
+ $(use_enable truetype xft) \
+ $(use_enable utempter) \
+ $(use_enable menubar) \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" docdir=/usr/share/doc/${PF} install || die
+ # Give mrxvt perms to update utmp
+ fowners root:utmp /usr/bin/mrxvt
+ fperms g+s /usr/bin/mrxvt
+ dodoc AUTHORS CREDITS ChangeLog FAQ NEWS README* TODO
+
+}
+
+pkg_postinst() {
+
+ if [[ -z $RXVT_TERM ]]; then
+ einfo
+ einfo "If you experience problems with curses programs, then this is"
+ einfo "most likely because of incorrectly set termcap / terminfo"
+ einfo "entries. To fix this you can dry and run (as user)"
+ einfo " tic /usr/share/doc/${P}/etc/mrxvt.terminfo"
+ einfo "Alternately, run the offending programs with TERM=xterm."
+ einfo
+ einfo "To emerge mrxvt with TERM=xterm by default, set the RXVT_TERM"
+ einfo "environment variable to 'xterm', or your desired default"
+ einfo "terminal name. Alternately you can put 'Mrxvt.termName: xterm'"
+ einfo "in your ~/.mrxvtrc, or /etc/mrxvt/mrxvtrc."
+ einfo
+ fi
+
+}