summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-18 16:07:36 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-18 16:07:36 +0000
commita8d8fe42e05bb29f39f14d7f3f65896f2c334cb0 (patch)
tree864ab9d6e5c096fc9624abcf527958eb4d1e87fc /x11-terms
parentbump (diff)
downloadgentoo-2-a8d8fe42e05bb29f39f14d7f3f65896f2c334cb0.tar.gz
gentoo-2-a8d8fe42e05bb29f39f14d7f3f65896f2c334cb0.tar.bz2
gentoo-2-a8d8fe42e05bb29f39f14d7f3f65896f2c334cb0.zip
Old.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/files/macosx-clipboard71
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.14-secondary-wheel.patch123
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch14
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.18.ebuild134
5 files changed, 6 insertions, 343 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 5ba143a1d1de..afe6627258c5 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.263 2014/05/18 10:16:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.264 2014/05/18 16:07:36 jer Exp $
+
+ 18 May 2014; Jeroen Roovers <jer@gentoo.org> -rxvt-unicode-9.18.ebuild,
+ -files/rxvt-unicode-9.14-secondary-wheel.patch,
+ -files/rxvt-unicode-9.19-fading.patch, -files/macosx-clipboard:
+ Old.
18 May 2014; Agostino Sarubbo <ago@gentoo.org> rxvt-unicode-9.20.ebuild:
Stable for x86, wrt bug #509174
diff --git a/x11-terms/rxvt-unicode/files/macosx-clipboard b/x11-terms/rxvt-unicode/files/macosx-clipboard
deleted file mode 100644
index 9e149586aa4c..000000000000
--- a/x11-terms/rxvt-unicode/files/macosx-clipboard
+++ /dev/null
@@ -1,71 +0,0 @@
-#! perl -w
-
-# ----------------------------------------------------------------------
-# File: macosx-clipboard
-# ----------------------------------------------------------------------
-#
-# All portions of code are copyright by their respective author/s.
-# Copyright (c) 2006 Samuel Ljungkvist <salj@triplefusion.net>
-# 2009 Reza Jelveh <reza.jelveh@gmail.com>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-# ----------------------------------------------------------------------
-
-# Usage:
-
-# URxvt.perl-ext-common: macosx-clipboard
-# URxvt.keysym.M-c: perl:macosx-clipboard:copy
-# URxvt.keysym.M-v: perl:macosx-clipboard:paste
-
-use Fcntl ();
-use Mac::Pasteboard;
-use locale;
-use utf8;
-
-our($pasteboard);
-
-$pasteboard = Mac::Pasteboard->new ();
-
-sub copy {
- my ($self) = @_;
-
- $pasteboard->clear ();
- $pasteboard->copy ($self->selection);
- ()
-}
-
-sub paste {
- my ($self) = @_;
- my ($str);
-
- $str = $pasteboard->paste();
- utf8::decode($str);
- $self->tt_write($self->locale_encode($str));
- ()
-}
-
-sub on_user_command {
- my ($self, $cmd) = @_;
-
- if ($cmd eq "macosx-clipboard:copy") {
- $self->copy;
- }
-
- if ($cmd eq "macosx-clipboard:paste") {
- $self->paste;
- }
- ()
-}
-
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.14-secondary-wheel.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.14-secondary-wheel.patch
deleted file mode 100644
index 1ed8904f493b..000000000000
--- a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.14-secondary-wheel.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-secondary wheel support:
-when using the mouse wheel, if you’re on secondary screen then no scrolling
-will occur, and instead some (3, to be exact) “fake” keystrokes will be sent to
-the running application.
-
-patch by jacky
-i.am.jack.mail@gmail.com
-http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/001491.html
-
-diff -r d5f9ea7306c4 -r cca1997c1a85 doc/rxvt.1.pod
---- a/doc/rxvt.1.pod Wed Dec 21 22:59:04 2011 +0100
-+++ b/doc/rxvt.1.pod Wed Dec 21 23:01:28 2011 +0100
-@@ -455,6 +455,11 @@
- Turn on/off secondary screen scroll (default enabled); resource
- B<secondaryScroll>.
-
-+=item B<-ssw>|B<+ssw>
-+
-+Turn on/off secondary screen wheel support (default disabled); resource
-+B<secondaryWheel>.
-+
- =item B<-hold>|B<+hold>
-
- Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
-@@ -1167,6 +1172,13 @@
- scrollback buffer and, when secondaryScreen is off, switching
- to/from the secondary screen will instead scroll the screen up.
-
-+=item B<secondaryWheel:> I<boolean>
-+
-+Turn on/off secondary wheel (default disabled). If enabled, when on
-+secondary screen, using the mouse wheel will not scroll in the buffer
-+but instead send 3 "fake" keystrokes (Up/Down arrow) to the running
-+application (allows e.g. natural scrolling in B<man>, B<less>, etc).
-+
- =item B<hold>: I<boolean>
-
- Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
-diff -r d5f9ea7306c4 -r cca1997c1a85 src/command.C
---- a/src/command.C Wed Dec 21 22:59:04 2011 +0100
-+++ b/src/command.C Wed Dec 21 23:01:28 2011 +0100
-@@ -2197,10 +2197,46 @@
- }
- else
- # endif
-+#ifndef NO_SECONDARY_SCREEN
- {
-- scr_page (v, i);
-- scrollBar.show (1);
-+ /* on SECONDARY screen, we send "fake" UP/DOWN keys instead
-+ * (this allows to scroll within man, less, etc) */
-+ if (option (Opt_secondaryWheel) && current_screen != PRIMARY)
-+ {
-+ XKeyEvent event;
-+ event.display = ev.display;
-+ event.window = ev.window;
-+ event.root = ev.root;
-+ event.subwindow = ev.subwindow;
-+ event.time = ev.time;
-+ event.x = ev.x;
-+ event.y = ev.y;
-+ event.x_root = ev.x_root;
-+ event.y_root = ev.y_root;
-+ event.same_screen = ev.same_screen;
-+ event.state = 0;
-+ event.keycode = XKeysymToKeycode(ev.display,
-+ (v == UP) ? XK_Up : XK_Down);
-+ for (i = 0; i < 3; ++i)
-+ {
-+ event.type = KeyPress;
-+ XSendEvent (event.display, event.window, True,
-+ KeyPressMask, (XEvent *) &event);
-+ event.type = KeyRelease;
-+ XSendEvent (event.display, event.window, True,
-+ KeyPressMask, (XEvent *) &event);
-+ }
-+ }
-+ /* on PRIMARY screen, we scroll in the buffer */
-+ else
-+#endif
-+ {
-+ scr_page (v, i);
-+ scrollBar.show (1);
-+ }
-+#ifndef NO_SECONDARY_SCREEN
- }
-+#endif
- }
- break;
- #endif
-diff -r d5f9ea7306c4 -r cca1997c1a85 src/optinc.h
---- a/src/optinc.h Wed Dec 21 22:59:04 2011 +0100
-+++ b/src/optinc.h Wed Dec 21 23:01:28 2011 +0100
-@@ -26,6 +26,7 @@
- def(cursorBlink)
- def(secondaryScreen)
- def(secondaryScroll)
-+ def(secondaryWheel)
- def(pastableTabs)
- def(cursorUnderline)
- #if ENABLE_FRILLS
-diff -r d5f9ea7306c4 -r cca1997c1a85 src/rsinc.h
---- a/src/rsinc.h Wed Dec 21 22:59:04 2011 +0100
-+++ b/src/rsinc.h Wed Dec 21 23:01:28 2011 +0100
-@@ -102,6 +102,7 @@
- #ifndef NO_SECONDARY_SCREEN
- def (secondaryScreen)
- def (secondaryScroll)
-+ def (secondaryWheel)
- #endif
- #ifdef OFF_FOCUS_FADING
- def (fade)
-diff -r d5f9ea7306c4 -r cca1997c1a85 src/xdefaults.C
---- a/src/xdefaults.C Wed Dec 21 22:59:04 2011 +0100
-+++ b/src/xdefaults.C Wed Dec 21 23:01:28 2011 +0100
-@@ -261,6 +261,7 @@
- #ifndef NO_SECONDARY_SCREEN
- BOOL (Rs_secondaryScreen, "secondaryScreen", "ssc", Opt_secondaryScreen, 0, "enable secondary screen"),
- BOOL (Rs_secondaryScroll, "secondaryScroll", "ssr", Opt_secondaryScroll, 0, "enable secondary screen scroll"),
-+ BOOL (Rs_secondaryWheel, "secondaryWheel", "ssw", Opt_secondaryWheel, 0, "enable secondary screen wheel"),
- #endif
- #if ENABLE_PERL
- RSTRG (Rs_perl_lib, "perl-lib", "string"), //, "colon-separated directories with extension scripts"),TODO
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch
deleted file mode 100644
index 2e89dd83f06d..000000000000
--- a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-fading.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://cvs.schmorp.de/rxvt-unicode/src/rxvtperl.xs?r1=1.216&r2=1.217
-
---- a/src/rxvtperl.xs
-+++ b/src/rxvtperl.xs
-@@ -818,7 +818,9 @@
- // TODO: should support all colour constants, create colorinc.h &c
- const_iv (Color_fg),
- const_iv (Color_bg),
-+#ifdef OFF_FOCUS_FADING
- const_iv (Color_fade),
-+#endif
- const_iv (Color_pointer_fg),
- const_iv (Color_pointer_bg),
- const_iv (Color_border),
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.18.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.18.ebuild
deleted file mode 100644
index df21d981ff5a..000000000000
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.18.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.18.ebuild,v 1.10 2014/01/07 15:20:46 jlec Exp $
-
-EAPI=4
-inherit autotools eutils
-
-DESCRIPTION="rxvt clone with xft and unicode support"
-HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
-SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="
- 256-color alt-font-width blink buffer-on-clear +focused-urgency
- fading-colors +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
- startup-notification xft unicode3 +vanilla wcwidth
-"
-
-RDEPEND="
- >=sys-libs/ncurses-5.7-r6
- kernel_Darwin? ( dev-perl/Mac-Pasteboard )
- media-libs/fontconfig
- perl? ( dev-lang/perl )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
- startup-notification? ( x11-libs/startup-notification )
- x11-libs/libX11
- x11-libs/libXrender
- xft? ( x11-libs/libXft )
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- x11-proto/xproto
-"
-
-RESTRICT="test"
-REQUIRED_USE="vanilla? ( !alt-font-width !buffer-on-clear focused-urgency !secondary-wheel !wcwidth )"
-
-src_prepare() {
- # fix for prefix not installing properly
- epatch \
- "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch \
- "${FILESDIR}"/${PN}-9.15-xsubpp.patch
-
- if ! use vanilla; then
- ewarn "You are going to include unsupported third-party bug fixes/features."
- ewarn "If you want even more control over patches, then set USE=vanilla"
- ewarn "and store your patch set in /etc/portage/patches/${CATEGORY}/${PF}/"
-
- use wcwidth && epatch doc/wcwidth.patch
-
- # bug #240165
- use focused-urgency || epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
-
- # bug #263638
- epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
-
- # bug #237271
- epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
-
- # support for wheel scrolling on secondary screens
- use secondary-wheel && epatch "${FILESDIR}"/${PN}-9.14-secondary-wheel.patch
-
- # ctrl-l buffer fix
- use buffer-on-clear && epatch "${FILESDIR}"/${PN}-9.14-clear.patch
-
- use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
- else
- epatch_user
- fi
-
- # kill the rxvt-unicode terminfo file - #192083
- sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=''
-
- use iso14755 || myconf='--disable-iso14755'
-
- econf --enable-everything \
- $(use_enable 256-color) \
- $(use_enable blink text-blink) \
- $(use_enable fading-colors fading) \
- $(use_enable font-styles) \
- $(use_enable mousewheel) \
- $(use_enable perl) \
- $(use_enable pixbuf) \
- $(use_enable startup-notification) \
- $(use_enable xft) \
- $(use_enable unicode3) \
- ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- sed -i \
- -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
- "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
-}
-
-src_install() {
- default
-
- dodoc \
- README.FAQ Changes doc/README* doc/changes.txt doc/etc/* doc/rxvt-tabbed
-
- make_desktop_entry urxvt rxvt-unicode utilities-terminal \
- "System;TerminalEmulator"
-}
-
-pkg_postinst() {
- if use buffer-on-clear; then
- ewarn "You have enabled the buffer-on-clear USE flag."
- ewarn "Please note that, although this works well for most prompts,"
- ewarn "there have been cases with fancy prompts, like bug #397829,"
- ewarn "where it caused issues. Proceed with caution."
- ewarn " (keep this terminal open until you make sure it works)"
- fi
- if use secondary-wheel; then
- elog "You have enabled the secondary-wheel USE flag."
- elog "This allows you to scroll in secondary screens"
- elog "(like mutt's message list/view or nano) using the mouse wheel."
- elog
- elog "To actually enable the feature you have to add"
- elog " URxvt*secondaryWheel: true"
- elog "in your ~/.Xdefaults file"
- fi
-}