summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-20 09:06:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-20 09:06:54 +0000
commit8a0cf2a63fd0b293c15422ec1f1a09dc54157a3d (patch)
treebbe00601b8fdc3d30c480197545a0f7e1acbeb34 /x11-terms
parentUnmask (diff)
downloadgentoo-2-8a0cf2a63fd0b293c15422ec1f1a09dc54157a3d.tar.gz
gentoo-2-8a0cf2a63fd0b293c15422ec1f1a09dc54157a3d.tar.bz2
gentoo-2-8a0cf2a63fd0b293c15422ec1f1a09dc54157a3d.zip
Security update
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt/ChangeLog7
-rw-r--r--x11-terms/rxvt/files/digest-rxvt-2.7.8-r61
-rw-r--r--x11-terms/rxvt/files/rxvt-2.7.8-security.patch41
-rw-r--r--x11-terms/rxvt/rxvt-2.7.8-r6.ebuild62
4 files changed, 110 insertions, 1 deletions
diff --git a/x11-terms/rxvt/ChangeLog b/x11-terms/rxvt/ChangeLog
index 0627751170b5..83cc2e6637aa 100644
--- a/x11-terms/rxvt/ChangeLog
+++ b/x11-terms/rxvt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.12 2003/03/03 10:21:49 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.13 2003/03/20 09:06:54 aliz Exp $
+
+*rxvt-2.7.8-r6 (20 Mar 2003)
+
+ 20 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update. Added Redhat patch.
*rxvt-2.7.9 (03 Mar 2003)
diff --git a/x11-terms/rxvt/files/digest-rxvt-2.7.8-r6 b/x11-terms/rxvt/files/digest-rxvt-2.7.8-r6
new file mode 100644
index 000000000000..d71a447c4606
--- /dev/null
+++ b/x11-terms/rxvt/files/digest-rxvt-2.7.8-r6
@@ -0,0 +1 @@
+MD5 e91b733b4f480f218db4b3b331ea42f6 rxvt-2.7.8.tar.gz 488213
diff --git a/x11-terms/rxvt/files/rxvt-2.7.8-security.patch b/x11-terms/rxvt/files/rxvt-2.7.8-security.patch
new file mode 100644
index 000000000000..109f32434e7d
--- /dev/null
+++ b/x11-terms/rxvt/files/rxvt-2.7.8-security.patch
@@ -0,0 +1,41 @@
+diff -ur rxvt-2.7.6/src/command.c rxvt-2.7.6-new/src/command.c
+--- rxvt-2.7.6/src/command.c Tue Feb 25 13:29:15 2003
++++ rxvt-2.7.6-new/src/command.c Tue Feb 25 13:27:23 2003
+@@ -2260,8 +2260,11 @@
+ * rxvt_menubar_dispatch() violates the constness of the string,
+ * so do it here
+ */
+- if (arg == XTerm_Menu)
++ if (arg == XTerm_Menu) {
++#if 0 /* SECURITY */
+ rxvt_menubar_dispatch(r, (char *)s);
++#endif
++ }
+ else
+ rxvt_xterm_seq(r, arg, (char *)s, eh);
+ free(s);
+@@ -2300,6 +2303,7 @@
+
+ assert(str != NULL);
+ switch (op) {
++
+ case XTerm_name:
+ rxvt_set_title(r, str);
+ /* FALLTHROUGH */
+@@ -2375,12 +2379,15 @@
+ case XTerm_font:
+ rxvt_change_font(r, 0, str);
+ break;
++#if 0 /* SECURITY! */
+ case XTerm_dumpscreen: /* no error notices */
+ if ((fd = open(str, O_RDWR | O_CREAT | O_EXCL, 0600)) >= 0) {
+ rxvt_scr_dump(r, fd);
+ close(fd);
+ }
+ break;
++#endif
++
+ }
+ }
+ /*----------------------------------------------------------------------*/
+
diff --git a/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild b/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild
new file mode 100644
index 000000000000..f988007f4e2a
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.8-r6.ebuild,v 1.1 2003/03/20 09:06:54 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rxvt -- nice small x11 terminal"
+SRC_URI="ftp://ftp.rxvt.org/pub/rxvt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc alpha sparc"
+IUSE="motif"
+HOMEPAGE="http://www.rxvt.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ motif? ( x11-libs/openmotif )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-security.patch
+
+ use motif && epatch ${FILESDIR}/${P}-azz4.diff
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-rxvt-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-menubar \
+ --enable-languages \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling || die
+
+ emake || die
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ install || die
+
+ cd ${S}/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}