summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-12-14 15:39:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-12-14 15:39:22 +0000
commit0fb7f968c334ac70966d3ba7de54bed4b116b021 (patch)
tree0a242c60bb863d1305e2e595f54fa2b329f82d46 /x11-terms
parentUpstream patch for CVE-2013-6629 and CVE-2013-6630. (diff)
downloadgentoo-2-0fb7f968c334ac70966d3ba7de54bed4b116b021.tar.gz
gentoo-2-0fb7f968c334ac70966d3ba7de54bed4b116b021.tar.bz2
gentoo-2-0fb7f968c334ac70966d3ba7de54bed4b116b021.zip
Grab a patch from upstream to fix the encoding in menu creation.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xfce4-terminal/ChangeLog9
-rw-r--r--x11-terms/xfce4-terminal/files/xfce4-terminal-0.6.2-fix-up-the-encoding-menu-creation.patch39
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-0.6.2-r1.ebuild36
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-terms/xfce4-terminal/ChangeLog b/x11-terms/xfce4-terminal/ChangeLog
index 3f4bf499a830..a1f1398dceaf 100644
--- a/x11-terms/xfce4-terminal/ChangeLog
+++ b/x11-terms/xfce4-terminal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-terms/xfce4-terminal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xfce4-terminal/ChangeLog,v 1.5 2013/05/05 19:17:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xfce4-terminal/ChangeLog,v 1.6 2013/12/14 15:39:22 ssuominen Exp $
+
+*xfce4-terminal-0.6.2-r1 (14 Dec 2013)
+
+ 14 Dec 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +files/xfce4-terminal-0.6.2-fix-up-the-encoding-menu-creation.patch,
+ +xfce4-terminal-0.6.2-r1.ebuild:
+ Grab a patch from upstream to fix the encoding in menu creation.
05 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-terminal-0.6.1.ebuild:
diff --git a/x11-terms/xfce4-terminal/files/xfce4-terminal-0.6.2-fix-up-the-encoding-menu-creation.patch b/x11-terms/xfce4-terminal/files/xfce4-terminal-0.6.2-fix-up-the-encoding-menu-creation.patch
new file mode 100644
index 000000000000..d33e2e52b4dd
--- /dev/null
+++ b/x11-terms/xfce4-terminal/files/xfce4-terminal-0.6.2-fix-up-the-encoding-menu-creation.patch
@@ -0,0 +1,39 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=10395
+
+--- terminal/terminal-encoding-action.c
++++ terminal/terminal-encoding-action.c
+@@ -253,7 +253,7 @@ terminal_encoding_action_menu_shown (GtkWidget *menu,
+ /* action to reset to the default */
+ default_label = g_strdup_printf (_("Default (%s)"), default_charset);
+ item = gtk_radio_menu_item_new_with_label (groups, default_label);
+- groups = g_slist_prepend (groups, item);
++ groups = gtk_radio_menu_item_get_group (GTK_RADIO_MENU_ITEM (item));
+ gtk_menu_shell_append (GTK_MENU_SHELL (menu), item);
+ gtk_check_menu_item_set_active (GTK_CHECK_MENU_ITEM (item), found);
+ g_signal_connect (G_OBJECT (item), "activate",
+@@ -267,7 +267,6 @@ terminal_encoding_action_menu_shown (GtkWidget *menu,
+ /* category item */
+ item = gtk_menu_item_new_with_label (_(terminal_encodings_names[n]));
+ gtk_menu_shell_append (GTK_MENU_SHELL (menu), item);
+- groups = g_slist_prepend (groups, item);
+ gtk_widget_show (item);
+
+ submenu = gtk_menu_new ();
+@@ -281,7 +280,7 @@ terminal_encoding_action_menu_shown (GtkWidget *menu,
+ break;
+
+ item2 = gtk_radio_menu_item_new_with_label (groups, charset);
+- groups = g_slist_prepend (groups, item2);
++ groups = gtk_radio_menu_item_get_group (GTK_RADIO_MENU_ITEM (item2));
+ gtk_menu_shell_append (GTK_MENU_SHELL (submenu), item2);
+ g_object_set_qdata (G_OBJECT (item2), encoding_action_quark, (gchar *) charset);
+ gtk_widget_show (item2);
+@@ -304,7 +303,7 @@ terminal_encoding_action_menu_shown (GtkWidget *menu,
+ {
+ /* add an action with the unknown charset */
+ item2 = gtk_radio_menu_item_new_with_label (groups, action->current);
+- groups = g_slist_prepend (groups, item2);
++ groups = gtk_radio_menu_item_get_group (GTK_RADIO_MENU_ITEM (item2));
+ g_object_set_qdata_full (G_OBJECT (item2), encoding_action_quark,
+ g_strdup (action->current), g_free);
+ gtk_menu_shell_append (GTK_MENU_SHELL (submenu), item2);
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-0.6.2-r1.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..8bd449a38fcf
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-0.6.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xfce4-terminal/xfce4-terminal-0.6.2-r1.ebuild,v 1.1 2013/12/14 15:39:22 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/terminal/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.26
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libX11
+ >=x11-libs/vte-0.28:0
+ >=xfce-base/libxfce4ui-4.10"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-fix-up-the-encoding-menu-creation.patch )
+
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS )
+}