summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-05 16:05:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-05 16:05:08 +0000
commited3875e6e37faf3fdf0a405fe482155520bf5f26 (patch)
tree035f2a46c9944ecec01bc9b8e98a256a40bdc496 /x11-terms/guake
parentalpha/ia64/sh/sparc stable wrt #329963 (diff)
downloadgentoo-2-ed3875e6e37faf3fdf0a405fe482155520bf5f26.tar.gz
gentoo-2-ed3875e6e37faf3fdf0a405fe482155520bf5f26.tar.bz2
gentoo-2-ed3875e6e37faf3fdf0a405fe482155520bf5f26.zip
Version bump wrt #336068 by "Florian".
(Portage version: 2.2_rc69/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/guake')
-rw-r--r--x11-terms/guake/ChangeLog9
-rw-r--r--x11-terms/guake/files/guake-0.4.2-int-ssl-port.patch16
-rw-r--r--x11-terms/guake/files/guake-0.4.2-prefs-spinbox.patch12
-rw-r--r--x11-terms/guake/guake-0.4.2.ebuild60
4 files changed, 96 insertions, 1 deletions
diff --git a/x11-terms/guake/ChangeLog b/x11-terms/guake/ChangeLog
index a4ba2c4d303a..cac3f1ef573f 100644
--- a/x11-terms/guake/ChangeLog
+++ b/x11-terms/guake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-terms/guake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/guake/ChangeLog,v 1.4 2010/08/08 02:05:42 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/guake/ChangeLog,v 1.5 2010/09/05 16:05:08 ssuominen Exp $
+
+*guake-0.4.2 (05 Sep 2010)
+
+ 05 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> +guake-0.4.2.ebuild,
+ +files/guake-0.4.2-int-ssl-port.patch,
+ +files/guake-0.4.2-prefs-spinbox.patch:
+ Version bump wrt #336068 by "Florian".
08 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
guake-0.4.1-r1.ebuild:
diff --git a/x11-terms/guake/files/guake-0.4.2-int-ssl-port.patch b/x11-terms/guake/files/guake-0.4.2-int-ssl-port.patch
new file mode 100644
index 000000000000..801e76fb10fc
--- /dev/null
+++ b/x11-terms/guake/files/guake-0.4.2-int-ssl-port.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/336068
+https://bugzilla.redhat.com/show_bug.cgi?id=626303
+http://guake.org/ticket/246
+
+--- src/guake.py
++++ src/guake.py
+@@ -1099,7 +1099,7 @@
+ ssl_port = port
+ else:
+ ssl_host = self.client.get_string('/system/proxy/secure_host')
+- ssl_port = self.client.get_string('/system/proxy/secure_port')
++ ssl_port = self.client.get_int('/system/proxy/secure_port')
+
+ if self.client.get_bool(proxy + 'use_authentication'):
+ auth_user = self.client.get_string(
+
diff --git a/x11-terms/guake/files/guake-0.4.2-prefs-spinbox.patch b/x11-terms/guake/files/guake-0.4.2-prefs-spinbox.patch
new file mode 100644
index 000000000000..0446ea14b927
--- /dev/null
+++ b/x11-terms/guake/files/guake-0.4.2-prefs-spinbox.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/336068
+
+--- data/prefs.glade
++++ data/prefs.glade
+@@ -445,7 +445,6 @@
+ <property name="visible">True</property>
+ <child>
+ <widget class="GtkLabel" id="lblChooseShell3">
+- <property name="width_request">120</property>
+ <property name="visible">True</property>
+ <property name="xalign">0</property>
+ <property name="label" translatable="yes">Scrollback lines:</property>
diff --git a/x11-terms/guake/guake-0.4.2.ebuild b/x11-terms/guake/guake-0.4.2.ebuild
new file mode 100644
index 000000000000..e6ef433bac17
--- /dev/null
+++ b/x11-terms/guake/guake-0.4.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/guake/guake-0.4.2.ebuild,v 1.1 2010/09/05 16:05:08 ssuominen Exp $
+
+EAPI=2
+
+GCONF_DEBUG=no
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils gnome2 python multilib
+
+DESCRIPTION="A dropdown terminal made for the GNOME desktop"
+HOMEPAGE="http://guake.org/"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${PN}_${PV}.orig.tar.gz"
+#SRC_URI="http://guake.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ dev-python/pygtk
+ x11-libs/vte[python]
+ dev-python/notify-python
+ dev-python/gconf-python
+ dev-python/dbus-python
+ >=gnome-base/gconf-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( dev-util/intltool )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="--disable-static
+ --disable-dependency-tracking
+ $(use_enable nls)"
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-int-ssl-port.patch \
+ "${FILESDIR}"/${P}-prefs-spinbox.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}