summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-07-09 09:24:52 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-07-09 09:24:52 +0000
commitf02f56af5a25701b2085892e0a19d2a05f1b20d5 (patch)
treeccf372f203e19ed25f4092ba6994c975e7475bb7 /x11-plugins
parentFix for gcc-4.3, bug #229063. Thanks to Bert Karwatzki <spasswolf@web.de>. (diff)
downloadgentoo-2-f02f56af5a25701b2085892e0a19d2a05f1b20d5.tar.gz
gentoo-2-f02f56af5a25701b2085892e0a19d2a05f1b20d5.tar.bz2
gentoo-2-f02f56af5a25701b2085892e0a19d2a05f1b20d5.zip
Version bump. Closes bug #223713.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmweather+/ChangeLog7
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.11.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/x11-plugins/wmweather+/ChangeLog b/x11-plugins/wmweather+/ChangeLog
index 34bc52f9e679..68d34da92e77 100644
--- a/x11-plugins/wmweather+/ChangeLog
+++ b/x11-plugins/wmweather+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmweather+
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmweather+/ChangeLog,v 1.21 2007/01/22 11:15:43 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmweather+/ChangeLog,v 1.22 2008/07/09 09:24:52 s4t4n Exp $
+
+*wmweather+-2.11 (09 Jul 2008)
+
+ 09 Jul 2008; Michele Noberasco <s4t4n@gentoo.org> wmweather+-2.11.ebuild:
+ Version bump. Closes bug #223713.
22 Jan 2007; Michele Noberasco <s4t4n@gentoo.org> wmweather+-2.9.ebuild:
Filter -optimize-sibling-calls out of CFLAGS. Closes bug #159280.
diff --git a/x11-plugins/wmweather+/wmweather+-2.11.ebuild b/x11-plugins/wmweather+/wmweather+-2.11.ebuild
new file mode 100644
index 000000000000..cd5e52b8ef02
--- /dev/null
+++ b/x11-plugins/wmweather+/wmweather+-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmweather+/wmweather+-2.11.ebuild,v 1.1 2008/07/09 09:24:52 s4t4n Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="A dockapp for displaying data collected from METAR, AVN, ETA, and MRF forecasts"
+HOMEPAGE="http://www.sourceforge.net/projects/wmweatherplus/"
+SRC_URI="mirror://sourceforge/wmweatherplus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="x11-wm/windowmaker
+ dev-libs/libpcre
+ >=net-misc/curl-7.17.1
+ x11-libs/libXpm"
+
+src_compile() {
+ append-flags "-fno-optimize-sibling-calls"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dobin wmweather+
+ dodoc ChangeLog HINTS README example.conf
+ doman wmweather+.1
+}