summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-06 07:48:33 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-06 07:48:33 +0000
commit91547a97a8c0868585560a8e2d357223c4cee30e (patch)
tree3aeca2ae4e0508e17bd41528dfb850dbefd0b84d /x11-plugins
parentVersion bump to fix bug #328735 (diff)
downloadgentoo-2-91547a97a8c0868585560a8e2d357223c4cee30e.tar.gz
gentoo-2-91547a97a8c0868585560a8e2d357223c4cee30e.tar.bz2
gentoo-2-91547a97a8c0868585560a8e2d357223c4cee30e.zip
Reworked Makefile patch, simplified ebuild. Closes bug #336091.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmacpimon/ChangeLog7
-rw-r--r--x11-plugins/wmacpimon/files/Makefile.patch21
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild17
3 files changed, 26 insertions, 19 deletions
diff --git a/x11-plugins/wmacpimon/ChangeLog b/x11-plugins/wmacpimon/ChangeLog
index 155e6ffda20f..cf04fc6a39e9 100644
--- a/x11-plugins/wmacpimon/ChangeLog
+++ b/x11-plugins/wmacpimon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmacpimon
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/ChangeLog,v 1.8 2008/12/02 11:29:52 s4t4n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/ChangeLog,v 1.9 2010/09/06 07:48:33 s4t4n Exp $
+
+ 06 Sep 2010; Michele Noberasco <s4t4n@gentoo.org>; wmacpimon-0.2.1.ebuild, files/Makefile.patch:
+ Reworked Makefile patch, simplified ebuild. Closes bug #336091.
02 Dec 2008; Michele Noberasco <s4t4n@gentoo.org>; wmacpimon-0.2.1.ebuild, files/Makefile.patch:
Fixed LDFLAGS ordering. See bug #248618.
diff --git a/x11-plugins/wmacpimon/files/Makefile.patch b/x11-plugins/wmacpimon/files/Makefile.patch
index e4a759b83ebd..aab28fc89392 100644
--- a/x11-plugins/wmacpimon/files/Makefile.patch
+++ b/x11-plugins/wmacpimon/files/Makefile.patch
@@ -1,13 +1,24 @@
---- Makefile 2002-11-26 22:53:07.000000000 +0100
-+++ Makefile.new 2008-12-02 12:25:29.000000000 +0100
-@@ -11,8 +11,10 @@
+--- Makefile 2010-09-06 11:33:16.000000000 +0200
++++ Makefile.new 2010-09-06 11:36:28.000000000 +0200
+@@ -1,8 +1,5 @@
+-OPT = -O3 -DACPI
+-
+-CC = gcc
+-CFLAGS = $(OPT) -Wall -I/usr/X11R6/include
+-LDFLAGS = $(OPT) -L/usr/X11R6/lib -lX11 -lXpm -lXext
++CFLAGS += -DACPI -Wall -I/usr/X11R6/include
++LIBS = -DACPI -L/usr/X11R6/lib -lX11 -lXpm -lXext
+
+ SRCS = wmacpimon.c libacpi.c
+ OBJS = wmacpimon.o libacpi.o
+@@ -11,8 +8,10 @@
all: wmacpimon wmacpimond
wmacpimon: $(OBJS)
-+ $(CC) $(CFLAGS) -o wmacpimon $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o wmacpimon $^ $(LIBS)
wmacpimond: $(OBJZ)
-+ $(CC) $(CFLAGS) -o wmacpimond $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o wmacpimond $^ $(LIBS)
clean:
rm -f *.o *~ wmacpimon wmacpimond trace *.out *.bb *.bbg
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index eb5a3f5a57cd..b0a33819171a 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.8 2008/12/02 11:29:52 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.9 2010/09/06 07:48:33 s4t4n Exp $
+EAPI=2
inherit eutils
DESCRIPTION="WMaker DockApp that monitors the temperature and Speedstep features in new ACPI-based systems."
@@ -20,24 +21,16 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
# patch wmacpimon.c file to set default path for
# wmacpimon.prc to /var/tmp/
- cd "${S}"
epatch "${FILESDIR}"/wmacpimon.c.patch
# fix LDFLAGS ordering. See bug #248618.
+ # fix LDFLAGS ordering again and other stuff. See bug #336091.
epatch "${FILESDIR}"/Makefile.patch
}
-src_compile() {
- emake CFLAGS="${CFLAGS} -DACPI -Wall" \
- LDFLAGS="${CFLAGS} -DACPI -lX11 -lXpm -lXext" \
- || die "emake failed."
-}
-
src_install() {
dobin wmacpimond wmacpimon || die "dobin failed."
dodoc AUTHORS ChangeLog README