summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-07-04 08:51:40 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-07-04 08:51:40 +0000
commit85834c385e0ce3bbac10ee9889749935e57b2194 (patch)
tree2ba0e2b7694b8c90c45c6ebd599936c33f1e76c1 /x11-plugins
parentVersion bump. (diff)
downloadgentoo-2-85834c385e0ce3bbac10ee9889749935e57b2194.tar.gz
gentoo-2-85834c385e0ce3bbac10ee9889749935e57b2194.tar.bz2
gentoo-2-85834c385e0ce3bbac10ee9889749935e57b2194.zip
Version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmhdplop/ChangeLog7
-rw-r--r--x11-plugins/wmhdplop/Manifest4
-rw-r--r--x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.71
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild52
4 files changed, 62 insertions, 2 deletions
diff --git a/x11-plugins/wmhdplop/ChangeLog b/x11-plugins/wmhdplop/ChangeLog
index 51430488aaae..9b7459838d9a 100644
--- a/x11-plugins/wmhdplop/ChangeLog
+++ b/x11-plugins/wmhdplop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmhdplop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.4 2005/05/22 10:22:17 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.5 2005/07/04 08:51:40 s4t4n Exp $
+
+*wmhdplop-0.9.7 (04 Jul 2005)
+
+ 04 Jul 2005; Michele Noberasco <s4t4n@gentoo.org> wmhdplop-0.9.7.ebuild:
+ Version bump.
22 May 2005; Simon Stelling <blubb@gentoo.org> wmhdplop-0.9.6.ebuild:
added ~amd64 keyword
diff --git a/x11-plugins/wmhdplop/Manifest b/x11-plugins/wmhdplop/Manifest
index 9b729649293e..401cd7f876f3 100644
--- a/x11-plugins/wmhdplop/Manifest
+++ b/x11-plugins/wmhdplop/Manifest
@@ -1,5 +1,7 @@
+MD5 1e13ad9fd53e81dbb010faddd3c2f42f wmhdplop-0.9.6.ebuild 1160
+MD5 989d243c13cb1f2d2f77392f5005cf29 wmhdplop-0.9.7.ebuild 1061
MD5 c849d3761e7d3b126af1a43722eb5249 ChangeLog 647
MD5 62ba71d3b2fa785a4cbd5d47fdbd0eb6 metadata.xml 165
-MD5 1e13ad9fd53e81dbb010faddd3c2f42f wmhdplop-0.9.6.ebuild 1160
MD5 eabbbed5a08e73895174ecb540e074ea files/digest-wmhdplop-0.9.6 66
+MD5 0a55dceead9ad7a2f7205718807cc4df files/digest-wmhdplop-0.9.7 66
MD5 2745de508ae424a95df9b4ec8cbd8a1a files/wmhdplop-cflags.patch 313
diff --git a/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7 b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7
new file mode 100644
index 000000000000..49abf1ec9f57
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7
@@ -0,0 +1 @@
+MD5 64984c0862319cce247f4aaedd1180c3 wmhdplop-0.9.7.tar.gz 221552
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild
new file mode 100644
index 000000000000..901538867ca7
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.7.ebuild,v 1.1 2005/07/04 08:51:40 s4t4n Exp $
+
+inherit eutils
+
+IUSE="gkrellm"
+
+DESCRIPTION="A fancy hard drive activity monitor dockapp"
+HOMEPAGE="http://hules.free.fr/wmhdplop"
+SRC_URI="http://hules.free.fr/wmhdplop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.2.0-r2
+ gkrellm? ( >=app-admin/gkrellm-2.1.28-r1 )"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Honour Gentoo CFLAGS, but retain some the package author chose himself
+ epatch ${FILESDIR}/${PN}-cflags.patch
+}
+
+src_compile()
+{
+ econf \
+ GENTOO_CFLAGS="${CFLAGS}" \
+ `use_enable gkrellm` \
+ || die "configure failed"
+
+ emake || die "parallel make failed"
+}
+
+src_install ()
+{
+ einstall || die "make install failed"
+
+ dodoc README AUTHORS ChangeLog
+
+ if use gkrellm; then
+ # I don't like hardcoded paths, but other
+ # gkrellm plugin ebuilds to it the same way...
+ exeinto /usr/lib/gkrellm2/plugins/
+ doexe gkhdplop.so
+ fi
+}